aboutsummaryrefslogtreecommitdiff
path: root/textproc/lucene4
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-01-24 22:32:36 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-01-24 22:32:36 +0000
commitf391c85c5c744e76528c82b83538b8e6c2ec10b9 (patch)
treea86d30d1f791a8c8d6c3253310fa92b735a2ac9d /textproc/lucene4
parent31d7e80a536538d40275975ff71bb1496421c709 (diff)
downloadports-f391c85c5c744e76528c82b83538b8e6c2ec10b9.tar.gz
ports-f391c85c5c744e76528c82b83538b8e6c2ec10b9.zip
- introduce Lucene 4.x branch to ports
- set CONFLICTS and LATEST_LINK accordingly
Notes
Notes: svn path=/head/; revision=310952
Diffstat (limited to 'textproc/lucene4')
-rw-r--r--textproc/lucene4/Makefile92
-rw-r--r--textproc/lucene4/distinfo2
-rw-r--r--textproc/lucene4/pkg-descr5
3 files changed, 99 insertions, 0 deletions
diff --git a/textproc/lucene4/Makefile b/textproc/lucene4/Makefile
new file mode 100644
index 000000000000..d667a6ae7bfe
--- /dev/null
+++ b/textproc/lucene4/Makefile
@@ -0,0 +1,92 @@
+# Created by: Jason Helfman <jgh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lucene
+PORTVERSION= 4.1.0
+CATEGORIES= textproc java devel
+MASTER_SITES= APACHE
+MASTER_SITE_SUBDIR= ${PORTNAME}/java/${PORTVERSION}/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mva@FreeBSD.org
+COMMENT= Full-text search engine for Java, 4.x branch
+
+LICENSE= AL2
+
+CONFLICTS= lucene-[0-9].*
+
+USE_JAVA= yes
+NO_BUILD= yes
+JAVA_VERSION= 1.6+
+
+OPTIONS_DEFINE= CONTRIB
+CONTRIB_DESC= Install contributed jars
+OPTIONS_DEFAULT= CONTRIB
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}-core-${PORTVERSION}.jar
+PKGNAMESUFFIX:= 4
+LASTEST_LINK= ${PORTNAME}4
+
+.include <bsd.port.options.mk>
+
+CONTRIBS= benchmark \
+ demo \
+ codecs \
+ facet \
+ grouping \
+ highlighter \
+ join \
+ memory \
+ misc \
+ queries \
+ queryparser \
+ sandbox \
+ spatial \
+ suggest
+
+EXTRA_CONTRIBS_DIRS= common \
+ icu \
+ kuromoji \
+ morfologik \
+ phonetic \
+ smartcn \
+ stempel \
+ uima
+
+.if ${PORT_OPTIONS:MCONTRIB}
+.for f in ${CONTRIBS}
+PLIST_FILES+=%%JAVAJARDIR%%/${PORTNAME}-${f}-${PORTVERSION}.jar
+.endfor
+.for g in ${EXTRA_CONTRIBS_DIRS}
+PLIST_FILES+=%%JAVAJARDIR%%/${PORTNAME}-analyzers-${g}-${PORTVERSION}.jar
+.endfor
+.endif
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/core/${PORTNAME}-core-${PORTVERSION}.jar ${JAVAJARDIR}
+.if ${PORT_OPTIONS:MCONTRIB}
+. for f in ${CONTRIBS}
+ ${INSTALL_DATA} ${WRKSRC}/${f}/${PORTNAME}-${f}-${PORTVERSION}.jar ${JAVAJARDIR}
+. endfor
+. for d in ${EXTRA_CONTRIBS_DIRS}
+ ${INSTALL_DATA} ${WRKSRC}/analysis/${d}/${PORTNAME}-analyzers-${d}-${PORTVERSION}.jar ${JAVAJARDIR}
+. endfor
+.endif
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for i in CHANGES.txt NOTICE.txt README.txt
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+ (cd ${WRKSRC}/docs && ${COPYTREE_SHARE} \* ${DOCSDIR})
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/demo/${PORTNAME}-demo-${PORTVERSION}.jar ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/lucene4/distinfo b/textproc/lucene4/distinfo
new file mode 100644
index 000000000000..c479d3ae0b6f
--- /dev/null
+++ b/textproc/lucene4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (lucene-4.1.0.tgz) = 6e0b88513d2c8eb2bf5c5da0a3266a823999158d7a9fa3dc015280d1860686c5
+SIZE (lucene-4.1.0.tgz) = 50047458
diff --git a/textproc/lucene4/pkg-descr b/textproc/lucene4/pkg-descr
new file mode 100644
index 000000000000..d570ad6496d7
--- /dev/null
+++ b/textproc/lucene4/pkg-descr
@@ -0,0 +1,5 @@
+Lucene 4.x is a Java full-text search engine. Lucene is not a complete
+application, but rather a code library and API that can easily be used
+to add search capabilities to applications.
+
+WWW: http://lucene.apache.org/java/