aboutsummaryrefslogtreecommitdiff
path: root/textproc/lucene
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-11 10:51:17 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-11 10:51:17 +0000
commit98e4fbfcc8ee59a13b9a3eae061107e6b9ae7660 (patch)
tree39d9a5d57ab5e644acafc2be49146c28d73fa1e7 /textproc/lucene
parentf3ef4f56b3aaffbe5d970c71343085ea658883da (diff)
downloadports-98e4fbfcc8ee59a13b9a3eae061107e6b9ae7660.tar.gz
ports-98e4fbfcc8ee59a13b9a3eae061107e6b9ae7660.zip
Lucene is a Java full-text search engine. Lucene is not a complete
application, but rather a code library and API that can easily be used to add search capabilities to applications. WWW: http://lucene.apache.org/java/ PR: ports/121537 Submitted by: Gerrit Beine <gerrit.beine at gmx.de>
Notes
Notes: svn path=/head/; revision=208794
Diffstat (limited to 'textproc/lucene')
-rw-r--r--textproc/lucene/Makefile61
-rw-r--r--textproc/lucene/distinfo3
-rw-r--r--textproc/lucene/pkg-descr5
3 files changed, 69 insertions, 0 deletions
diff --git a/textproc/lucene/Makefile b/textproc/lucene/Makefile
new file mode 100644
index 000000000000..72d1cd8d5c83
--- /dev/null
+++ b/textproc/lucene/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: lucene
+# Date created: 02 Jan 2008
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+
+PORTNAME= lucene
+PORTVERSION= 2.3.1
+CATEGORIES= textproc java devel
+MASTER_SITES= ${MASTER_SITE_APACHE:S,%SUBDIR%,lucene/java,}
+DISTNAME= lucene-${PORTVERSION}
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= A full-text search engine for Java
+
+NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+
+OPTIONS= DOCS "Install docs & examples" on
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}-core-${PORTVERSION}.jar
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_DOCS) || !defined(WITH_DOCS)
+NOPORTDOCS= yes
+.endif
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+DEMODIR= src/demo/org/apache/lucene/demo
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-core-${PORTVERSION}.jar ${JAVAJARDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/CHANGES.txt ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/LICENSE.txt ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/NOTICE.txt ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+ @cd ${WRKSRC}/docs/ \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/${DEMODIR} \
+ && ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} \;
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${FIND} -s ${WRKSRC}/${DEMODIR} -not -type d \
+ | ${SED} -ne 's,^${WRKSRC}/${DEMODIR},${EXAMPLESDIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${WRKSRC}/${DEMODIR} -type d \
+ | ${SED} -ne 's,^${WRKSRC}/${DEMODIR},@dirrm ${EXAMPLESDIR:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/lucene/distinfo b/textproc/lucene/distinfo
new file mode 100644
index 000000000000..7d040fb48e78
--- /dev/null
+++ b/textproc/lucene/distinfo
@@ -0,0 +1,3 @@
+MD5 (lucene-2.3.1.tar.gz) = 5bf11cc19adb469f272c12590182f50f
+SHA256 (lucene-2.3.1.tar.gz) = 6b5399dcce60ac8cad45a2a840c8e38a37104a72a75ab46505198ff206be6caf
+SIZE (lucene-2.3.1.tar.gz) = 6721058
diff --git a/textproc/lucene/pkg-descr b/textproc/lucene/pkg-descr
new file mode 100644
index 000000000000..20bb47507fe1
--- /dev/null
+++ b/textproc/lucene/pkg-descr
@@ -0,0 +1,5 @@
+Lucene is a Java full-text search engine. Lucene is not a complete
+application, but rather a code library and API that can easily be used
+to add search capabilities to applications.
+
+WWW: http://lucene.apache.org/java/