aboutsummaryrefslogtreecommitdiff
path: root/textproc/man2html
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-09-29 16:51:17 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-09-29 16:51:17 +0000
commit02f79e99bea61f2afe655238700005eb77d3d675 (patch)
tree7656f9c48ea95696e1644b8681ddbdc341368660 /textproc/man2html
parente0cd6e146845ab92984351fefc65e62a502d2ed9 (diff)
downloadports-02f79e99bea61f2afe655238700005eb77d3d675.tar.gz
ports-02f79e99bea61f2afe655238700005eb77d3d675.zip
- Fix man.cgi
- Change maintainer's e-mail PR: 21591 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=33255
Diffstat (limited to 'textproc/man2html')
-rw-r--r--textproc/man2html/Makefile10
-rw-r--r--textproc/man2html/files/patch-aa19
2 files changed, 19 insertions, 10 deletions
diff --git a/textproc/man2html/Makefile b/textproc/man2html/Makefile
index c55e87c2351a..c207d9bb700e 100644
--- a/textproc/man2html/Makefile
+++ b/textproc/man2html/Makefile
@@ -11,7 +11,7 @@ CATEGORIES= textproc
MASTER_SITES= ftp://ftp.gpad.ac.ru/pub/FreeBSD/distfiles/
DISTNAME= ${PORTNAME}${PORTVERSION}
-MAINTAINER= demon@gpad.ac.ru
+MAINTAINER= dima@Chg.RU
USE_PERL5= yes
NO_BUILD= yes
@@ -20,13 +20,7 @@ CGIDIR= ${PREFIX}/www/cgi-bin
MAN1= man2html.1
post-patch:
-
- @ if [ -f ${CGIDIR} ] ; then \
- @ ${MV} ${WRKSRC}/man.cgi ${WRKSRC}/man.cgi.pre_sed ; \
- @ ${CAT} ${WRKSRC}/man.cgi.pre_sed | \
- @ ${GREP} -Ev -e "/opt/|/openwin/" \
- > ${WRKSRC}/man.cgi ; \
- fi
+ ${PERL} -pi -e "s#/usr/local/bin/perl#${PERL5}#" ${WRKSRC}/man.cgi
do-install:
diff --git a/textproc/man2html/files/patch-aa b/textproc/man2html/files/patch-aa
index 5c23812daa07..323a2425df80 100644
--- a/textproc/man2html/files/patch-aa
+++ b/textproc/man2html/files/patch-aa
@@ -1,5 +1,11 @@
---- man.cgi.orig Tue Aug 12 21:19:18 1997
-+++ man.cgi Mon Nov 30 17:18:04 1998
+--- man.cgi.orig Wed Aug 13 01:19:18 1997
++++ man.cgi Sat Sep 30 00:46:55 2000
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl5.00503
+ ##---------------------------------------------------------------------------##
+ ## File:
+ ## @(#) man.cgi 1.2 97/08/12 12:58:26 @(#)
@@ -59,8 +59,8 @@
## systems. If using Tom Christiansen's Perl man program, than
## define use "".
@@ -50,3 +56,12 @@
/bin
/usr/bin
);
+@@ -270,7 +269,7 @@
+
+ # Convert output from man to html
+ #--------------------------------
+- close(STDERR);
++ open(STDERR, ">&/dev/null");
+ open(MANPRG, "-|") or exec($ManPrg, @manargs);
+ $Man2Html::InFH = \*MANPRG; # set input filehandle
+ require $ManConvPrg or