aboutsummaryrefslogtreecommitdiff
path: root/textproc/opensp/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-10-31 04:33:39 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-10-31 04:33:39 +0000
commita5fc954d9dd6b8931e531ea42d56d4e82987ea3f (patch)
treebc6a726e7a1577d4007972aab1dc5cf4bb8741ce /textproc/opensp/Makefile
parent95935b92193bb1bd96162a9d0236b37a89d43080 (diff)
downloadports-a5fc954d9dd6b8931e531ea42d56d4e82987ea3f.tar.gz
ports-a5fc954d9dd6b8931e531ea42d56d4e82987ea3f.zip
o Add explicit dependency on libiconv and gettext.
o Honor $NOPORTDOCS. PR ports/58540 Submitted by: Simon Barner <barner@in.tum.de>
Notes
Notes: svn path=/head/; revision=92676
Diffstat (limited to 'textproc/opensp/Makefile')
-rw-r--r--textproc/opensp/Makefile42
1 files changed, 40 insertions, 2 deletions
diff --git a/textproc/opensp/Makefile b/textproc/opensp/Makefile
index cbb821792ac5..350387027e2e 100644
--- a/textproc/opensp/Makefile
+++ b/textproc/opensp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= OpenSP
PORTVERSION= 1.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= openjade
@@ -15,14 +15,32 @@ MASTER_SITE_SUBDIR= openjade
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= This package is a collection of SGML/XML tools called OpenSP
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
+
USE_GMAKE= YES
+USE_REINPLACE= YES
USE_LIBTOOL= YES
USE_PERL5= yes
+USE_AUTOCONF_VER=253
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
--datadir=${PREFIX}/share/sgml/openjade
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+
INSTALLS_SHLIB= yes
-MAN1= onsgmls.1 osgmlnorm.1 ospam.1 ospent.1 osx.1
+MAN1= onsgmls.1 osgmlnorm.1 ospam.1 ospent.1 osx.1
+DOC_FILES= archform.htm autoconf.htm build.htm catalog.htm charset.htm \
+ features.htm generic.htm ideas.htm index.htm new.htm \
+ nsgmls.htm sgmldecl.htm sgmlnorm.htm sgmlsout.htm spam.htm \
+ spcat.htm spent.htm sx.htm sysdecl.htm sysid.htm xml.htm \
+ xmlwarn.htm
+DOC_FILES2= NEWS AUTHORS README \
+ releasenotes.html releasenotes.pdf releasenotes.ps
+
+# Perhaps this better should be somewhere under ${PREFIX}/share/doc ?
+DOCSDIR2= ${PREFIX}/share/sgml/openjade/doc/OpenSP
.include <bsd.port.pre.mk>
@@ -32,4 +50,24 @@ MAN1= onsgmls.1 osgmlnorm.1 ospam.1 ospent.1 osx.1
# other than -O{0,1,}. Idea taken from palm/prc-tools-gcc.
CPPFLAGS:= -O ${CFLAGS:N-O*:N-m*}
+pre-install:
+ @${REINPLACE_CMD} -e \
+ 's|install-man install-pkgdocDATA|install-man|g' \
+ ${WRKSRC}/Makefile
+
+post-install:
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${doc} ${DOCSDIR}
+.endfor
+
+ @${MKDIR} ${DOCSDIR2}
+.for doc in ${DOC_FILES2}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR2}
+.endfor
+
+.endif
+
.include <bsd.port.post.mk>