aboutsummaryrefslogtreecommitdiff
path: root/textproc/opensp
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-28 07:32:19 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-28 07:32:19 +0000
commita2073fe88270445b9b26129a79b6dfbf068b2323 (patch)
tree3f3bba427780f895b013093540eff861f7b65ce5 /textproc/opensp
parentd169182964804b1466a6f03e81c340fffcec80fe (diff)
downloadports-a2073fe88270445b9b26129a79b6dfbf068b2323.tar.gz
ports-a2073fe88270445b9b26129a79b6dfbf068b2323.zip
Support stage
Be less creative about DOCS installation Add NLS and DOCS options
Notes
Notes: svn path=/head/; revision=341501
Diffstat (limited to 'textproc/opensp')
-rw-r--r--textproc/opensp/Makefile36
-rw-r--r--textproc/opensp/pkg-plist30
2 files changed, 11 insertions, 55 deletions
diff --git a/textproc/opensp/Makefile b/textproc/opensp/Makefile
index 7eaffd9b2988..d4ef9d75c149 100644
--- a/textproc/opensp/Makefile
+++ b/textproc/opensp/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= SF/openjade/${PORTNAME:L}/${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= This package is a collection of SGML/XML tools called OpenSP
+OPTIONS_DEFINE= DOCS NLS
+
USE_LDCONFIG= yes
USES= gmake iconv perl5
GNU_CONFIGURE= yes
@@ -19,20 +21,12 @@ CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -I${LOCALBASE}/include
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+OPTIONS_SUB= yes
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext
-#MAN1= onsgmls.1 osgmlnorm.1 ospam.1 ospent.1 osx.1
-.include <bsd.port.pre.mk>
+PORTDOCS= *.htm NEWS AUTHORS README ABOUT-NLS BUGS ChangeLog
# This port cannot be CFLAGS safe, using optimizations such as
# 'march=-mpentium -Os' produces core dumps with certain input files
@@ -41,16 +35,8 @@ PLIST_SUB+= NLS="@comment "
CPPFLAGS:= -O ${CFLAGS:N-O*:N-m*}
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${CAT} ${PLIST} | \
- ${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} | \
- ${AWK} '/^@comment INSTALL_DATA:/ \
- {printf "if ! ${GREP} -q \"%s\" ${PLIST}; then ${ECHO_CMD} \"%s\" >> %s; fi; %s %s/%s %s/%s\n", \
- $$4, $$4, "${TMPPLIST}", "${INSTALL_DATA}", \
- "${WRKSRC}", $$3, "${PREFIX}", $$4}' | \
- ${SH} && \
- ${ECHO_CMD} "@dirrm ${DOCSDIR:S,^${PREFIX}/,,}" >> ${TMPPLIST}
-.endif
-
-.include <bsd.port.post.mk>
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.htm ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS:N\*.htm} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/opensp/pkg-plist b/textproc/opensp/pkg-plist
index ca554a230b5c..fb1941523f83 100644
--- a/textproc/opensp/pkg-plist
+++ b/textproc/opensp/pkg-plist
@@ -151,36 +151,6 @@ lib/libosp.so.5
%%NLS%%share/locale/ja/LC_MESSAGES/sp5.mo
%%NLS%%share/locale/sv/LC_MESSAGES/sp5.mo
%%NLS%%share/locale/tr/LC_MESSAGES/sp5.mo
-@comment the following lines used for installation of doc files
-@comment INSTALL_DATA: doc/archform.htm %%DOCSDIR%%/archform.htm
-@comment INSTALL_DATA: doc/autoconf.htm %%DOCSDIR%%/autoconf.htm
-@comment INSTALL_DATA: doc/build.htm %%DOCSDIR%%/build.htm
-@comment INSTALL_DATA: doc/catalog.htm %%DOCSDIR%%/catalog.htm
-@comment INSTALL_DATA: doc/charset.htm %%DOCSDIR%%/charset.htm
-@comment INSTALL_DATA: doc/features.htm %%DOCSDIR%%/features.htm
-@comment INSTALL_DATA: doc/generic.htm %%DOCSDIR%%/generic.htm
-@comment INSTALL_DATA: doc/ideas.htm %%DOCSDIR%%/ideas.htm
-@comment INSTALL_DATA: doc/index.htm %%DOCSDIR%%/index.htm
-@comment INSTALL_DATA: doc/new.htm %%DOCSDIR%%/new.htm
-@comment INSTALL_DATA: doc/nsgmls.htm %%DOCSDIR%%/nsgmls.htm
-@comment INSTALL_DATA: doc/sgmldecl.htm %%DOCSDIR%%/sgmldecl.htm
-@comment INSTALL_DATA: doc/sgmlnorm.htm %%DOCSDIR%%/sgmlnorm.htm
-@comment INSTALL_DATA: doc/sgmlsout.htm %%DOCSDIR%%/sgmlsout.htm
-@comment INSTALL_DATA: doc/spam.htm %%DOCSDIR%%/spam.htm
-@comment INSTALL_DATA: doc/spcat.htm %%DOCSDIR%%/spcat.htm
-@comment INSTALL_DATA: doc/spent.htm %%DOCSDIR%%/spent.htm
-@comment INSTALL_DATA: doc/sx.htm %%DOCSDIR%%/sx.htm
-@comment INSTALL_DATA: doc/sysdecl.htm %%DOCSDIR%%/sysdecl.htm
-@comment INSTALL_DATA: doc/sysid.htm %%DOCSDIR%%/sysid.htm
-@comment INSTALL_DATA: doc/xml.htm %%DOCSDIR%%/xml.htm
-@comment INSTALL_DATA: doc/xmlwarn.htm %%DOCSDIR%%/xmlwarn.htm
-@comment INSTALL_DATA: NEWS %%DOCSDIR%%/NEWS
-@comment INSTALL_DATA: AUTHORS %%DOCSDIR%%/AUTHORS
-@comment INSTALL_DATA: README %%DOCSDIR%%/README
-@comment INSTALL_DATA: ABOUT-NLS %%DOCSDIR%%/ABOUT-NLS
-@comment INSTALL_DATA: BUGS %%DOCSDIR%%/BUGS
-@comment INSTALL_DATA: COPYING %%DOCSDIR%%/COPYING
-@comment INSTALL_DATA: ChangeLog %%DOCSDIR%%/ChangeLog
share/sgml/openjade/OpenSP/HTML32.dcl
share/sgml/openjade/OpenSP/HTML32.dtd
share/sgml/openjade/OpenSP/HTML32.soc