aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-CSS-SAC/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-07-07 14:32:21 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-07-07 14:32:21 +0000
commit1fcbecd506ea0335caf0593b61f4ff3cf8825456 (patch)
tree8c82c6d264ebe417d0d48a557e5a02e1f2625614 /textproc/p5-CSS-SAC/Makefile
parent0976c7a20c66cab843721cb4c6d142b6bffb2e5f (diff)
downloadports-1fcbecd506ea0335caf0593b61f4ff3cf8825456.tar.gz
ports-1fcbecd506ea0335caf0593b61f4ff3cf8825456.zip
Add p5-CSS-SAC 0.04, SAC CSS (Simple API for CSS) parser.
Notes
Notes: svn path=/head/; revision=62562
Diffstat (limited to 'textproc/p5-CSS-SAC/Makefile')
-rw-r--r--textproc/p5-CSS-SAC/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/textproc/p5-CSS-SAC/Makefile b/textproc/p5-CSS-SAC/Makefile
new file mode 100644
index 000000000000..48b95ba7b4b5
--- /dev/null
+++ b/textproc/p5-CSS-SAC/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: CSS-SAC
+# Date created: 07 July 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CSS-SAC
+PORTVERSION= 0.04
+CATEGORIES= textproc perl5 www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CSS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/ArrayObjects.pm:${PORTSDIR}/devel/p5-Class-ArrayObjects
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= CSS::SAC.3 CSS::SAC::Condition.3 \
+ CSS::SAC::Condition::Attribute.3 \
+ CSS::SAC::Condition::Combinator.3 \
+ CSS::SAC::Condition::Content.3 CSS::SAC::Condition::Lang.3 \
+ CSS::SAC::Condition::Negative.3 \
+ CSS::SAC::Condition::Positional.3 CSS::SAC::ConditionFactory.3 \
+ CSS::SAC::LexicalUnit.3 CSS::SAC::Selector.3 \
+ CSS::SAC::Selector::CharacterData.3 \
+ CSS::SAC::Selector::Conditional.3 \
+ CSS::SAC::Selector::Descendant.3 CSS::SAC::Selector::Element.3 \
+ CSS::SAC::Selector::Negative.3 \
+ CSS::SAC::Selector::ProcessingInstruction.3 \
+ CSS::SAC::Selector::Sibling.3 CSS::SAC::Selector::Simple.3 \
+ CSS::SAC::SelectorFactory.3 CSS::SAC::SelectorList.3 \
+ CSS::SAC::TestWriter.3 CSS::SAC::Writer.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>