aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-EBook-Tools
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-23 20:58:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-23 20:58:38 +0000
commitc04a70f4be65134a343897d6b061dd0f007c74b8 (patch)
tree863ebc4bee127a715f42283f9c691b7bd62b0e6e /textproc/p5-EBook-Tools
parent3262b5369b86acac2c5f0b53e16354549a9dfd21 (diff)
downloadports-c04a70f4be65134a343897d6b061dd0f007c74b8.tar.gz
ports-c04a70f4be65134a343897d6b061dd0f007c74b8.zip
EBook-Tools contains a library and a command-line tool for unpacking,
creating, correcting, and repacking electronic books. Current unpacking support is limited to PalmDoc and Mobipocket and generation is limited to EPub. The metadata correction tools are quite extensive, however. For more details, see the POD information on EBook::Tools and EBook::Tools::Unpack. WWW: http://search.cpan.org/dist/EBook-Tools/ PR: ports/131901 Submitted by: simond at irrelevant.org
Notes
Notes: svn path=/head/; revision=228948
Diffstat (limited to 'textproc/p5-EBook-Tools')
-rw-r--r--textproc/p5-EBook-Tools/Makefile39
-rw-r--r--textproc/p5-EBook-Tools/distinfo3
-rw-r--r--textproc/p5-EBook-Tools/pkg-descr9
-rw-r--r--textproc/p5-EBook-Tools/pkg-plist15
4 files changed, 66 insertions, 0 deletions
diff --git a/textproc/p5-EBook-Tools/Makefile b/textproc/p5-EBook-Tools/Makefile
new file mode 100644
index 000000000000..2bbac7fd10d4
--- /dev/null
+++ b/textproc/p5-EBook-Tools/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-EBook-Tools
+# Date created: 20 February 2009
+# Whom: simond@irrelevant.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= EBook-Tools
+PORTVERSION= 0.4.3
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= simond@irrelevant.org
+COMMENT= Object class for manipulating and generating E-books
+
+BUILD_DEPENDS= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
+ ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
+ ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles \
+ ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ ${SITE_PERL}/File/MimeInfo.pm:${PORTSDIR}/devel/p5-File-MimeInfo \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash \
+ ${SITE_PERL}/Time/Local.pm:${PORTSDIR}/devel/p5-Time-Local \
+ ${SITE_PERL}/XML/Twig.pm:${PORTSDIR}/textproc/p5-XML-Twig \
+ ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp \
+ ${SITE_PERL}/Palm/PDB.pm:${PORTSDIR}/palm/p5-Palm \
+ ${SITE_PERL}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
+ ${SITE_PERL}/${PERL_ARCH}/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32 \
+ ${SITE_PERL}/HTML/TextToHTML.pm:${PORTSDIR}/textproc/txt2html
+RUN_DEPENDS+= ${LOCALBASE}/bin/tidy:${PORTSDIR}/www/tidy
+
+PERL_CONFIGURE= yes
+
+MAN3= EBook::Tools::Unpack.3 EBook::Tools::MSReader.3 EBook::Tools::LZSS.3 \
+ EBook::Tools::Mobipocket.3 EBook::ebook.3 EBook::Tools::EReader.3 \
+ EBook::Tools::IMP.3 EBook::Tools::PalmDoc.3 EBook::Tools.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-EBook-Tools/distinfo b/textproc/p5-EBook-Tools/distinfo
new file mode 100644
index 000000000000..ef9165c79ea7
--- /dev/null
+++ b/textproc/p5-EBook-Tools/distinfo
@@ -0,0 +1,3 @@
+MD5 (EBook-Tools-0.4.3.tar.gz) = f7a4a20285ff457df3e15b0caf99e63b
+SHA256 (EBook-Tools-0.4.3.tar.gz) = cb680ab5d30cea1d8b6d2c707c5bf472b1110fb7ebdb1b8bd876592539a36ffc
+SIZE (EBook-Tools-0.4.3.tar.gz) = 602814
diff --git a/textproc/p5-EBook-Tools/pkg-descr b/textproc/p5-EBook-Tools/pkg-descr
new file mode 100644
index 000000000000..417d1074109e
--- /dev/null
+++ b/textproc/p5-EBook-Tools/pkg-descr
@@ -0,0 +1,9 @@
+EBook-Tools contains a library and a command-line tool for unpacking,
+creating, correcting, and repacking electronic books.
+
+Current unpacking support is limited to PalmDoc and Mobipocket and
+generation is limited to EPub. The metadata correction tools are
+quite extensive, however. For more details, see the POD information
+on EBook::Tools and EBook::Tools::Unpack.
+
+WWW: http://search.cpan.org/dist/EBook-Tools/
diff --git a/textproc/p5-EBook-Tools/pkg-plist b/textproc/p5-EBook-Tools/pkg-plist
new file mode 100644
index 000000000000..c8072a629308
--- /dev/null
+++ b/textproc/p5-EBook-Tools/pkg-plist
@@ -0,0 +1,15 @@
+%%SITE_PERL%%/EBook/Tools.pm
+%%SITE_PERL%%/EBook/Tools/EReader.pm
+%%SITE_PERL%%/EBook/Tools/IMP.pm
+%%SITE_PERL%%/EBook/Tools/LZSS.pm
+%%SITE_PERL%%/EBook/Tools/MSReader.pm
+%%SITE_PERL%%/EBook/Tools/Mobipocket.pm
+%%SITE_PERL%%/EBook/Tools/PalmDoc.pm
+%%SITE_PERL%%/EBook/Tools/Unpack.pm
+%%SITE_PERL%%/EBook/ebook.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/EBook/Tools/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/EBook/Tools
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/EBook
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/EBook/Tools
+@dirrmtry %%SITE_PERL%%/EBook