aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Google-Data-JSON
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-05 17:54:34 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-05 17:54:34 +0000
commit1f853f4d86cac7617064804f4e24488ff3b7a766 (patch)
tree8af602d901ded41e48d986b38253f6cb4387eb34 /textproc/p5-Google-Data-JSON
parentf1a9b0f994790e63dfd30ac5834c6b6c394c8920 (diff)
downloadports-1f853f4d86cac7617064804f4e24488ff3b7a766.tar.gz
ports-1f853f4d86cac7617064804f4e24488ff3b7a766.zip
- Update to 0.1.10
- Fix *_DEPENDS: version is already in some supported Perl releases - Sort *_DEPENDS - Use TEST_DEPENDS for test-only dependencies Changes: http://search.cpan.org/dist/Google-Data-JSON/Changes Feature safe: yes
Notes
Notes: svn path=/head/; revision=294247
Diffstat (limited to 'textproc/p5-Google-Data-JSON')
-rw-r--r--textproc/p5-Google-Data-JSON/Makefile28
-rw-r--r--textproc/p5-Google-Data-JSON/distinfo4
-rw-r--r--textproc/p5-Google-Data-JSON/pkg-plist4
3 files changed, 24 insertions, 12 deletions
diff --git a/textproc/p5-Google-Data-JSON/Makefile b/textproc/p5-Google-Data-JSON/Makefile
index 9499c54f3597..4efa2dc70657 100644
--- a/textproc/p5-Google-Data-JSON/Makefile
+++ b/textproc/p5-Google-Data-JSON/Makefile
@@ -6,30 +6,38 @@
#
PORTNAME= Google-Data-JSON
-PORTVERSION= 0.1.5
+PORTVERSION= 0.1.10
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= HTML/TAKERU
+MASTER_SITE_SUBDIR= CPAN:TAKERU
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= perl@FreeBSD.org
COMMENT= General XML-JSON converter based on Google Data APIs
-BUILD_DEPENDS= p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any \
- p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+BUILD_DEPENDS= p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-Perl6-Export-Attrs>=0:${PORTSDIR}/devel/p5-Perl6-Export-Attrs \
- p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings \
p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
- p5-version>=0:${PORTSDIR}/devel/p5-version \
- p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
- p5-Test-Perl-Critic>=0:${PORTSDIR}/textproc/p5-Test-Perl-Critic \
p5-XML-Atom>=0:${PORTSDIR}/textproc/p5-XML-Atom \
p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+TEST_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ p5-Test-Perl-Critic>=0:${PORTSDIR}/textproc/p5-Test-Perl-Critic
+
+PERL_CONFIGURE= yes
MAN3= Google::Data::JSON.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-version>=0:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS+= p5-version>=0:${PORTSDIR}/devel/p5-version
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Google-Data-JSON/distinfo b/textproc/p5-Google-Data-JSON/distinfo
index c5bddd8a5559..8f00f433c279 100644
--- a/textproc/p5-Google-Data-JSON/distinfo
+++ b/textproc/p5-Google-Data-JSON/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Google-Data-JSON-0.1.5.tar.gz) = 96b85663cb7f51933f7404672cf31510249b33816431fcf543d57c41af00f05e
-SIZE (Google-Data-JSON-0.1.5.tar.gz) = 6700
+SHA256 (Google-Data-JSON-v0.1.10.tar.gz) = 835f87012e6daf56cd98e150ed29a5e906e988ca872da485253d6edb3f7a16f6
+SIZE (Google-Data-JSON-v0.1.10.tar.gz) = 9445
diff --git a/textproc/p5-Google-Data-JSON/pkg-plist b/textproc/p5-Google-Data-JSON/pkg-plist
index 133f25b6e1a0..f9776d7aa3a5 100644
--- a/textproc/p5-Google-Data-JSON/pkg-plist
+++ b/textproc/p5-Google-Data-JSON/pkg-plist
@@ -1,3 +1,7 @@
%%SITE_PERL%%/Google/Data/JSON.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/Data/JSON/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/Data/JSON
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google/Data
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Google
@dirrmtry %%SITE_PERL%%/Google/Data
@dirrmtry %%SITE_PERL%%/Google