aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-MKDoc-XML
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-25 22:55:23 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-25 22:55:23 +0000
commit21d57492ac70cde3589955970d0a96dedc651daa (patch)
treec2cb8e3c4b8d8a46c960e5fdfabd54081e587c1b /textproc/p5-MKDoc-XML
parent60fc88b53594629e4e0073de765f9801c811d9b9 (diff)
downloadports-21d57492ac70cde3589955970d0a96dedc651daa.tar.gz
ports-21d57492ac70cde3589955970d0a96dedc651daa.zip
Adding port textproc/p5-MKDoc-XML, The MKDoc XML Toolkit.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163435
Diffstat (limited to 'textproc/p5-MKDoc-XML')
-rw-r--r--textproc/p5-MKDoc-XML/Makefile40
-rw-r--r--textproc/p5-MKDoc-XML/distinfo3
-rw-r--r--textproc/p5-MKDoc-XML/pkg-descr23
-rw-r--r--textproc/p5-MKDoc-XML/pkg-plist26
4 files changed, 92 insertions, 0 deletions
diff --git a/textproc/p5-MKDoc-XML/Makefile b/textproc/p5-MKDoc-XML/Makefile
new file mode 100644
index 000000000000..9f840aa0b5ce
--- /dev/null
+++ b/textproc/p5-MKDoc-XML/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-MKDoc-XML
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MKDoc-XML
+PORTVERSION= 0.75
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/B/BP/BPOSTLE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= The MKDoc XML Toolkit
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= MKDoc::XML.3 \
+ MKDoc::XML::Decode.3 \
+ MKDoc::XML::Dumper.3 \
+ MKDoc::XML::Encode.3 \
+ MKDoc::XML::Stripper.3 \
+ MKDoc::XML::Tagger.3 \
+ MKDoc::XML::Token.3 \
+ MKDoc::XML::Tokenizer.3 \
+ MKDoc::XML::TreeBuilder.3 \
+ MKDoc::XML::TreePrinter.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-MKDoc-XML/distinfo b/textproc/p5-MKDoc-XML/distinfo
new file mode 100644
index 000000000000..9493c649cd06
--- /dev/null
+++ b/textproc/p5-MKDoc-XML/distinfo
@@ -0,0 +1,3 @@
+MD5 (MKDoc-XML-0.75.tar.gz) = bae96f16d2f55ac01f562d2e101b2824
+SHA256 (MKDoc-XML-0.75.tar.gz) = be938c99a5e5951dc0abe4ffcb7557b15f45b74ed5232e70aac9a102e7165aa8
+SIZE (MKDoc-XML-0.75.tar.gz) = 40990
diff --git a/textproc/p5-MKDoc-XML/pkg-descr b/textproc/p5-MKDoc-XML/pkg-descr
new file mode 100644
index 000000000000..127378a4ea84
--- /dev/null
+++ b/textproc/p5-MKDoc-XML/pkg-descr
@@ -0,0 +1,23 @@
+MKDoc is a web content management system written in Perl which focuses on
+standards compliance, accessiblity and usability issues, and multi-lingual
+websites.
+
+At MKDoc Ltd we have decided to gradually break up our existing commercial
+software into a collection of completely independent, well-documented,
+well-tested open-source CPAN modules.
+
+Ultimately we want MKDoc code to be a coherent collection of module
+distributions, yet each distribution should be usable and useful in
+itself.
+
+MKDoc::XML is part of this effort.
+
+You could help us and turn some of MKDoc's code into a CPAN module. You
+can take a look at the existing code at http://download.mkdoc.org/.
+
+If you are interested in some functionality which you would like to see as
+a standalone CPAN module, send an email to
+<mkdoc-modules@lists.webarch.co.uk>
+
+WWW: http://search.cpan.org/dist/MKDoc-XML
+Author: Jean-Michel Hiver
diff --git a/textproc/p5-MKDoc-XML/pkg-plist b/textproc/p5-MKDoc-XML/pkg-plist
new file mode 100644
index 000000000000..e52e373bdfcd
--- /dev/null
+++ b/textproc/p5-MKDoc-XML/pkg-plist
@@ -0,0 +1,26 @@
+%%SITE_PERL%%/MKDoc/XML.pm
+%%SITE_PERL%%/MKDoc/XML/Decode.pm
+%%SITE_PERL%%/MKDoc/XML/Decode/Numeric.pm
+%%SITE_PERL%%/MKDoc/XML/Decode/XHTML.pm
+%%SITE_PERL%%/MKDoc/XML/Decode/XMLBase.pm
+%%SITE_PERL%%/MKDoc/XML/Dumper.pm
+%%SITE_PERL%%/MKDoc/XML/Encode.pm
+%%SITE_PERL%%/MKDoc/XML/Stripper.pm
+%%SITE_PERL%%/MKDoc/XML/Stripper/mkdoc16.txt
+%%SITE_PERL%%/MKDoc/XML/Stripper/xhtml10frameset.txt
+%%SITE_PERL%%/MKDoc/XML/Stripper/xhtml10strict.txt
+%%SITE_PERL%%/MKDoc/XML/Stripper/xhtml10transitional.txt
+%%SITE_PERL%%/MKDoc/XML/Tagger.pm
+%%SITE_PERL%%/MKDoc/XML/Tagger/Preserve.pm
+%%SITE_PERL%%/MKDoc/XML/Token.pm
+%%SITE_PERL%%/MKDoc/XML/Tokenizer.pm
+%%SITE_PERL%%/MKDoc/XML/TreeBuilder.pm
+%%SITE_PERL%%/MKDoc/XML/TreePrinter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MKDoc/XML/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/MKDoc/XML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MKDoc
+@dirrm %%SITE_PERL%%/MKDoc/XML/Tagger
+@dirrm %%SITE_PERL%%/MKDoc/XML/Stripper
+@dirrm %%SITE_PERL%%/MKDoc/XML/Decode
+@dirrm %%SITE_PERL%%/MKDoc/XML
+@dirrmtry %%SITE_PERL%%/MKDoc