aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-PDF-FromHTML
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /textproc/p5-PDF-FromHTML
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'textproc/p5-PDF-FromHTML')
-rw-r--r--textproc/p5-PDF-FromHTML/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/textproc/p5-PDF-FromHTML/Makefile b/textproc/p5-PDF-FromHTML/Makefile
index a8659f864b8c..b46ef7dbd1ff 100644
--- a/textproc/p5-PDF-FromHTML/Makefile
+++ b/textproc/p5-PDF-FromHTML/Makefile
@@ -11,13 +11,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Convert HTML documents to PDF
-BUILD_DEPENDS= p5-HTML-Tidy>=0:${PORTSDIR}/textproc/p5-HTML-Tidy \
- p5-Graphics-ColorNames>=0:${PORTSDIR}/graphics/p5-Graphics-ColorNames \
+BUILD_DEPENDS= p5-Graphics-ColorNames>=0:${PORTSDIR}/graphics/p5-Graphics-ColorNames \
+ p5-HTML-Tidy>=0:${PORTSDIR}/textproc/p5-HTML-Tidy \
p5-Image-Size>=0:${PORTSDIR}/graphics/p5-Image-Size \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-PDF-API2>=0:${PORTSDIR}/textproc/p5-PDF-API2 \
+ p5-PDF-Writer>=0.05:${PORTSDIR}/textproc/p5-PDF-Writer \
p5-XML-Twig>=0:${PORTSDIR}/textproc/p5-XML-Twig \
- p5-PDF-Writer>=0.05:${PORTSDIR}/textproc/p5-PDF-Writer
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5