aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Petal-Mail
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-26 18:28:08 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-26 18:28:08 +0000
commitfd75220bc8c1f95991f6d14b9313b502465e9202 (patch)
treeb52d0a008abb329c86108b312640ae32d6417765 /textproc/p5-Petal-Mail
parent5f0a8b79a8b48bd5ebb939fbd465c2d57a6208c4 (diff)
downloadports-fd75220bc8c1f95991f6d14b9313b502465e9202.tar.gz
ports-fd75220bc8c1f95991f6d14b9313b502465e9202.zip
Adding port textproc/p5-Petal-Mail, Format text e-mail using Petal.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163522
Diffstat (limited to 'textproc/p5-Petal-Mail')
-rw-r--r--textproc/p5-Petal-Mail/Makefile32
-rw-r--r--textproc/p5-Petal-Mail/distinfo3
-rw-r--r--textproc/p5-Petal-Mail/pkg-descr9
-rw-r--r--textproc/p5-Petal-Mail/pkg-plist6
4 files changed, 50 insertions, 0 deletions
diff --git a/textproc/p5-Petal-Mail/Makefile b/textproc/p5-Petal-Mail/Makefile
new file mode 100644
index 000000000000..d4da873fa550
--- /dev/null
+++ b/textproc/p5-Petal-Mail/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Petal-Mail
+# Date created: 26 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Petal-Mail
+PORTVERSION= 0.31
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/B/BP/BPOSTLE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Format text e-mail using Petal
+
+BUILD_DEPENDS= ${SITE_PERL}/Petal.pm:${PORTSDIR}/textproc/p5-Petal \
+ ${SITE_PERL}/${PERL_ARCH}/Encode.pm:${PORTSDIR}/devel/p5-Encode
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Petal::Mail.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+IGNORE= requires at least Perl 5.7.3 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Petal-Mail/distinfo b/textproc/p5-Petal-Mail/distinfo
new file mode 100644
index 000000000000..a1a4f8831050
--- /dev/null
+++ b/textproc/p5-Petal-Mail/distinfo
@@ -0,0 +1,3 @@
+MD5 (Petal-Mail-0.31.tar.gz) = 16c56abfef21499d7f9c3f374f1e41e7
+SHA256 (Petal-Mail-0.31.tar.gz) = 5012346850284189e6f59948c88715443ef0b6b72ae258d1295e95a8c0feccd1
+SIZE (Petal-Mail-0.31.tar.gz) = 7567
diff --git a/textproc/p5-Petal-Mail/pkg-descr b/textproc/p5-Petal-Mail/pkg-descr
new file mode 100644
index 000000000000..73000e6f2780
--- /dev/null
+++ b/textproc/p5-Petal-Mail/pkg-descr
@@ -0,0 +1,9 @@
+Petal::Mail processes a Petal XML template, and then turns the resulting
+XML into a text email which can be sent through sendmail or other. The XML
+has to follow a certain syntax which is defined in this documentation.
+
+Since Petal::Mail's is a subclass of Petal, its API is the same. Which
+means you need to read about Petal before you can use Petal::Mail.
+
+WWW: http://search.cpan.org/dist/Petal-Mail
+Author: Jean-Michel Hiver
diff --git a/textproc/p5-Petal-Mail/pkg-plist b/textproc/p5-Petal-Mail/pkg-plist
new file mode 100644
index 000000000000..35b701e4fd2e
--- /dev/null
+++ b/textproc/p5-Petal-Mail/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Petal/Mail.pm
+%%SITE_PERL%%/Petal/fake_sendmail.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Petal/Mail/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Petal/Mail
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Petal
+@dirrmtry %%SITE_PERL%%/Petal