aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Petal-Utils
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-26 18:44:51 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-26 18:44:51 +0000
commit25f54cb85b332b51ad6d8481b68650a703df0676 (patch)
tree8f1dc32717f09a08fcfef3cd6588a23b970e0a24 /textproc/p5-Petal-Utils
parentf8105b37527ea59431b6085c0c386e13a35228d7 (diff)
downloadports-25f54cb85b332b51ad6d8481b68650a703df0676.tar.gz
ports-25f54cb85b332b51ad6d8481b68650a703df0676.zip
Adding port textproc/p5-Petal-Utils, Useful template modifiers for Petal.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163528
Diffstat (limited to 'textproc/p5-Petal-Utils')
-rw-r--r--textproc/p5-Petal-Utils/Makefile33
-rw-r--r--textproc/p5-Petal-Utils/distinfo3
-rw-r--r--textproc/p5-Petal-Utils/pkg-descr29
-rw-r--r--textproc/p5-Petal-Utils/pkg-plist25
4 files changed, 90 insertions, 0 deletions
diff --git a/textproc/p5-Petal-Utils/Makefile b/textproc/p5-Petal-Utils/Makefile
new file mode 100644
index 000000000000..3dd0aecf1d02
--- /dev/null
+++ b/textproc/p5-Petal-Utils/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Petal-Utils
+# Date created: 26 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Petal-Utils
+PORTVERSION= 0.06
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/W/WM/WMCKEE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Useful template modifiers for Petal
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${SITE_PERL}/Petal.pm:${PORTSDIR}/textproc/p5-Petal \
+ ${SITE_PERL}/Date/Format.pm:${PORTSDIR}/devel/p5-TimeDate \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+
+MAN3= Petal::Utils.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Petal-Utils/distinfo b/textproc/p5-Petal-Utils/distinfo
new file mode 100644
index 000000000000..0c7ceecff4b2
--- /dev/null
+++ b/textproc/p5-Petal-Utils/distinfo
@@ -0,0 +1,3 @@
+MD5 (Petal-Utils-0.06.tar.gz) = d93d4e1724a967891b4974b6985986cb
+SHA256 (Petal-Utils-0.06.tar.gz) = 0c52abee16a15d2c4ab5b1885a9c24ff5215f05c2274bb1514f1a18526a2839f
+SIZE (Petal-Utils-0.06.tar.gz) = 17048
diff --git a/textproc/p5-Petal-Utils/pkg-descr b/textproc/p5-Petal-Utils/pkg-descr
new file mode 100644
index 000000000000..8aaa28afa2d1
--- /dev/null
+++ b/textproc/p5-Petal-Utils/pkg-descr
@@ -0,0 +1,29 @@
+The Petal::Utils package contains commonly used Petal modifiers (or
+plugins), and bundles them with an easy-to-use installation interface. By
+default, a set of modifiers are installed into Petal when you use this
+module. You can change which modifiers are installed by naming them after
+the use statement:
+
+ # use the default set:
+ use Petal::Utils qw( :default );
+
+ # use the date set of modifiers:
+ use Petal::Utils qw( :date );
+
+ # use only named modifiers, plus the debug set:
+ use Petal::Utils qw( UpperCase Date :debug );
+
+ # don't install any modifiers
+ use Petal::Utils qw();
+
+You'll find a list of plugin sets throughout this document. You can also
+get a complete list by looking at the variable:
+
+ %Petal::Utils::PLUGIN_SET;
+
+For details on how the plugins are installed, see the "Advanced Petal"
+section of the Petal documentation.
+
+WWW: http://search.cpan.org/dist/Petal-Utils
+Author: William McKee <william@knowmad.com>
+ Steve Purkis <spurkis@cpan.org>
diff --git a/textproc/p5-Petal-Utils/pkg-plist b/textproc/p5-Petal-Utils/pkg-plist
new file mode 100644
index 000000000000..ccb7c4e68f15
--- /dev/null
+++ b/textproc/p5-Petal-Utils/pkg-plist
@@ -0,0 +1,25 @@
+%%SITE_PERL%%/Petal/Utils.pm
+%%SITE_PERL%%/Petal/Utils/And.pm
+%%SITE_PERL%%/Petal/Utils/Base.pm
+%%SITE_PERL%%/Petal/Utils/Create_Href.pm
+%%SITE_PERL%%/Petal/Utils/Date.pm
+%%SITE_PERL%%/Petal/Utils/Decode.pm
+%%SITE_PERL%%/Petal/Utils/Dump.pm
+%%SITE_PERL%%/Petal/Utils/Each.pm
+%%SITE_PERL%%/Petal/Utils/Equal.pm
+%%SITE_PERL%%/Petal/Utils/If.pm
+%%SITE_PERL%%/Petal/Utils/Keys.pm
+%%SITE_PERL%%/Petal/Utils/Like.pm
+%%SITE_PERL%%/Petal/Utils/Limit.pm
+%%SITE_PERL%%/Petal/Utils/Limitr.pm
+%%SITE_PERL%%/Petal/Utils/LowerCase.pm
+%%SITE_PERL%%/Petal/Utils/Or.pm
+%%SITE_PERL%%/Petal/Utils/Printf.pm
+%%SITE_PERL%%/Petal/Utils/Sort.pm
+%%SITE_PERL%%/Petal/Utils/Substr.pm
+%%SITE_PERL%%/Petal/Utils/UC_First.pm
+%%SITE_PERL%%/Petal/Utils/US_Date.pm
+%%SITE_PERL%%/Petal/Utils/UpperCase.pm
+%%SITE_PERL%%/Petal/Utils/UriEscape.pm
+@dirrm %%SITE_PERL%%/Petal/Utils
+@dirrmtry %%SITE_PERL%%/Petal