aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Plucene-Analysis-CJKAnalyzer
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-07-09 05:16:53 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-07-09 05:16:53 +0000
commitc39ecaf873831f768334507d28f1cc9cf2dfa7a3 (patch)
tree1b5e217d7109d24bdc6cf7cf64c3096dc856ac11 /textproc/p5-Plucene-Analysis-CJKAnalyzer
parenta8a0a1e8ca72dab512535d30840ed25a6ea25bf2 (diff)
downloadports-c39ecaf873831f768334507d28f1cc9cf2dfa7a3.tar.gz
ports-c39ecaf873831f768334507d28f1cc9cf2dfa7a3.zip
This is a text analyzer for analyzing CJK texts. Plucene does not
support CJK texts natively. This module encodes terms in MIME::Base64 format to get around this problem. Texts are assumbed to be in UTF-8 encoding. WWW: http://search.cpan.org/dist/Plucene-Analysis-CJKAnalyzer/ PR: ports/114376 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=195269
Diffstat (limited to 'textproc/p5-Plucene-Analysis-CJKAnalyzer')
-rw-r--r--textproc/p5-Plucene-Analysis-CJKAnalyzer/Makefile26
-rw-r--r--textproc/p5-Plucene-Analysis-CJKAnalyzer/distinfo3
-rw-r--r--textproc/p5-Plucene-Analysis-CJKAnalyzer/pkg-descr6
-rw-r--r--textproc/p5-Plucene-Analysis-CJKAnalyzer/pkg-plist9
4 files changed, 44 insertions, 0 deletions
diff --git a/textproc/p5-Plucene-Analysis-CJKAnalyzer/Makefile b/textproc/p5-Plucene-Analysis-CJKAnalyzer/Makefile
new file mode 100644
index 000000000000..85e778563016
--- /dev/null
+++ b/textproc/p5-Plucene-Analysis-CJKAnalyzer/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Plucene-Analysis-CJKAnalyzer
+# Date created: 2007-07-07
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plucene-Analysis-CJKAnalyzer
+PORTVERSION= 0.02
+CATEGORIES= textproc
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/X/XE/XERN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Analyzer for CJK texts
+
+RUN_DEPENDS= ${SITE_PERL}/Plucene.pm:${PORTSDIR}/textproc/p5-Plucene
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Plucene::Analysis::CJKAnalyzer.3 \
+ Plucene::Analysis::CJKTokenizer.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Plucene-Analysis-CJKAnalyzer/distinfo b/textproc/p5-Plucene-Analysis-CJKAnalyzer/distinfo
new file mode 100644
index 000000000000..1542d4a30438
--- /dev/null
+++ b/textproc/p5-Plucene-Analysis-CJKAnalyzer/distinfo
@@ -0,0 +1,3 @@
+MD5 (Plucene-Analysis-CJKAnalyzer-0.02.tar.gz) = 15999ae03734ca1eae43176619b21585
+SHA256 (Plucene-Analysis-CJKAnalyzer-0.02.tar.gz) = 8c813f6a1c37b62fe966b95fefaf3e5d927856710013d573bc71b5864041b97d
+SIZE (Plucene-Analysis-CJKAnalyzer-0.02.tar.gz) = 24890
diff --git a/textproc/p5-Plucene-Analysis-CJKAnalyzer/pkg-descr b/textproc/p5-Plucene-Analysis-CJKAnalyzer/pkg-descr
new file mode 100644
index 000000000000..4492bddfc190
--- /dev/null
+++ b/textproc/p5-Plucene-Analysis-CJKAnalyzer/pkg-descr
@@ -0,0 +1,6 @@
+This is a text analyzer for analyzing CJK texts. Plucene does not
+support CJK texts natively. This module encodes terms in MIME::Base64
+format to get around this problem. Texts are assumbed to be in UTF-8
+encoding.
+
+WWW: http://search.cpan.org/dist/Plucene-Analysis-CJKAnalyzer/
diff --git a/textproc/p5-Plucene-Analysis-CJKAnalyzer/pkg-plist b/textproc/p5-Plucene-Analysis-CJKAnalyzer/pkg-plist
new file mode 100644
index 000000000000..422a7bc77609
--- /dev/null
+++ b/textproc/p5-Plucene-Analysis-CJKAnalyzer/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plucene/Analysis/CJKAnalyzer/.packlist
+%%SITE_PERL%%/Plucene/Analysis/CJKAnalyzer.pm
+%%SITE_PERL%%/Plucene/Analysis/CJKTokenizer.pm
+@dirrmtry %%SITE_PERL%%/Plucene/Analysis
+@dirrmtry %%SITE_PERL%%/Plucene
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plucene/Analysis/CJKAnalyzer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plucene/Analysis
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plucene