aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-Simple
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-07-02 17:59:32 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-07-02 17:59:32 +0000
commitfd22f4947016f35aa085ed3d965c1db74ae0571c (patch)
tree43c97d47e3316b232ed57f1749e3fcda1261ff1a /textproc/p5-Pod-Simple
parent62b5f32bad290ce69ce9469069fa4a0ae9dccfb4 (diff)
downloadports-fd22f4947016f35aa085ed3d965c1db74ae0571c.tar.gz
ports-fd22f4947016f35aa085ed3d965c1db74ae0571c.zip
Add p5-Pod-Simple 0.96, framework for parsing Pod.
PR: 54018 Submitted by: Mathieu Arnold <m@absolight.net>
Notes
Notes: svn path=/head/; revision=84057
Diffstat (limited to 'textproc/p5-Pod-Simple')
-rw-r--r--textproc/p5-Pod-Simple/Makefile33
-rw-r--r--textproc/p5-Pod-Simple/distinfo1
-rw-r--r--textproc/p5-Pod-Simple/pkg-descr11
-rw-r--r--textproc/p5-Pod-Simple/pkg-plist29
4 files changed, 74 insertions, 0 deletions
diff --git a/textproc/p5-Pod-Simple/Makefile b/textproc/p5-Pod-Simple/Makefile
new file mode 100644
index 000000000000..55a086bf71ae
--- /dev/null
+++ b/textproc/p5-Pod-Simple/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Pod-Simple # Date created: 2 july 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-Simple
+PORTVERSION= 0.96
+CATEGORIES= textproc devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Pod
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Framework for parsing Pod
+
+BUILD_DEPENDS= ${SITE_PERL}/Text/Wrap.pm:${PORTSDIR}/textproc/p5-Text-Tabs+Wrap \
+ ${SITE_PERL}/Pod/Escapes.pm:${PORTSDIR}/textproc/p5-Pod-Escapes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Pod::Simple.3 Pod::Simple::Checker.3 Pod::Simple::Debug.3 \
+ Pod::Simple::DumpAsText.3 Pod::Simple::DumpAsXML.3 \
+ Pod::Simple::HTML.3 Pod::Simple::LinkSection.3 \
+ Pod::Simple::Methody.3 Pod::Simple::PullParser.3 \
+ Pod::Simple::PullParserEndToken.3 Pod::Simple::PullParserStartToken.3 \
+ Pod::Simple::PullParserTextToken.3 Pod::Simple::PullParserToken.3 \
+ Pod::Simple::RTF.3 Pod::Simple::SimpleTree.3 Pod::Simple::Subclassing.3 \
+ Pod::Simple::Text.3 Pod::Simple::TextContent.3 \
+ Pod::Simple::XMLOutStream.3 perlpod.3 perlpodspec.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Simple/distinfo b/textproc/p5-Pod-Simple/distinfo
new file mode 100644
index 000000000000..2c75976ef3f5
--- /dev/null
+++ b/textproc/p5-Pod-Simple/distinfo
@@ -0,0 +1 @@
+MD5 (Pod-Simple-0.96.tar.gz) = 502276e97230708ea97bd6510786ec58
diff --git a/textproc/p5-Pod-Simple/pkg-descr b/textproc/p5-Pod-Simple/pkg-descr
new file mode 100644
index 000000000000..124956cfe85b
--- /dev/null
+++ b/textproc/p5-Pod-Simple/pkg-descr
@@ -0,0 +1,11 @@
+Pod::Simple is a Perl library for parsing text in the Pod ("plain old
+documentation") markup language that is typically used for writing
+documentation for Perl and for Perl modules. The Pod format is explained in the
+perlpod man page; the most common formatter is called "perldoc".
+
+Pod formatters can use Pod::Simple to parse Pod documents into produce
+renderings of them in plain ASCII, in HTML, or in any number of other formats.
+Typically, such formatters will be subclasses of Pod::Simple, and so they will
+inherit its methods, like parse_file.
+
+WWW: http://search.cpan.org/dist/Pod-Simple/
diff --git a/textproc/p5-Pod-Simple/pkg-plist b/textproc/p5-Pod-Simple/pkg-plist
new file mode 100644
index 000000000000..20c017862f3d
--- /dev/null
+++ b/textproc/p5-Pod-Simple/pkg-plist
@@ -0,0 +1,29 @@
+%%SITE_PERL%%/Pod/Simple.pm
+%%SITE_PERL%%/Pod/Simple.pod
+%%SITE_PERL%%/Pod/Simple/BlackBox.pm
+%%SITE_PERL%%/Pod/Simple/Checker.pm
+%%SITE_PERL%%/Pod/Simple/Debug.pm
+%%SITE_PERL%%/Pod/Simple/DumpAsText.pm
+%%SITE_PERL%%/Pod/Simple/DumpAsXML.pm
+%%SITE_PERL%%/Pod/Simple/HTML.pm
+%%SITE_PERL%%/Pod/Simple/LinkSection.pm
+%%SITE_PERL%%/Pod/Simple/Methody.pm
+%%SITE_PERL%%/Pod/Simple/PullParser.pm
+%%SITE_PERL%%/Pod/Simple/PullParserEndToken.pm
+%%SITE_PERL%%/Pod/Simple/PullParserStartToken.pm
+%%SITE_PERL%%/Pod/Simple/PullParserTextToken.pm
+%%SITE_PERL%%/Pod/Simple/PullParserToken.pm
+%%SITE_PERL%%/Pod/Simple/RTF.pm
+%%SITE_PERL%%/Pod/Simple/SimpleTree.pm
+%%SITE_PERL%%/Pod/Simple/Subclassing.pod
+%%SITE_PERL%%/Pod/Simple/Text.pm
+%%SITE_PERL%%/Pod/Simple/TextContent.pm
+%%SITE_PERL%%/Pod/Simple/TiedOutFH.pm
+%%SITE_PERL%%/Pod/Simple/XMLOutStream.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Simple/.packlist
+%%SITE_PERL%%/perlpod.pod
+%%SITE_PERL%%/perlpodspec.pod
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Simple
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Pod/Simple
+@unexec rmdir %D/%%SITE_PERL%%/Pod 2>/dev/null || true