aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-RDF-Simple/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-02 15:53:28 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-02 15:53:28 +0000
commit0f257398f95aa318d1bee0ffed60b70c1e19adb6 (patch)
tree12d7ddb0122753ffd1240ab94b76f30a670f9991 /textproc/p5-RDF-Simple/Makefile
parentffefbe8037c403a80b92eedeb306e5f897ffee5f (diff)
downloadports-0f257398f95aa318d1bee0ffed60b70c1e19adb6.tar.gz
ports-0f257398f95aa318d1bee0ffed60b70c1e19adb6.zip
Add p5-RDF-Simple 0.13, read and write RDF without complication.
PR: ports/69872 Submitted by: Aaron Straup Cope <ascope@cpan.org>
Notes
Notes: svn path=/head/; revision=115274
Diffstat (limited to 'textproc/p5-RDF-Simple/Makefile')
-rw-r--r--textproc/p5-RDF-Simple/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/p5-RDF-Simple/Makefile b/textproc/p5-RDF-Simple/Makefile
new file mode 100644
index 000000000000..7f81be36402d
--- /dev/null
+++ b/textproc/p5-RDF-Simple/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-RDF-Simple
+# Date created: July 12 2004
+# Whom: Aaron Straup Cope <ascope@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RDF-Simple
+PORTVERSION= 0.13
+# PORTREVISION=
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= RDF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ascope@cpan.org
+COMMENT= Read and write RDF without complication
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= RDF::Simple.3 RDF::Simple::Parser.3 RDF::Simple::Serialiser.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars q{$$1};$$1/g' \
+ ${WRKSRC}/lib/RDF/Simple.pm ${WRKSRC}/lib/RDF/Simple/*.pm
+.endif
+
+.include <bsd.port.post.mk>