aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-SGML-Parser-OpenSP
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-07 23:18:28 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2010-03-07 23:18:28 +0000
commit484d01977666cc9f0ef9345ca0f4ced48070a32a (patch)
treeacdba5854e07528da9d15703c321b6e5ee824235 /textproc/p5-SGML-Parser-OpenSP
parenta2d5cbb6d5af67f2345858a12b11a128a0d04990 (diff)
downloadports-484d01977666cc9f0ef9345ca0f4ced48070a32a.tar.gz
ports-484d01977666cc9f0ef9345ca0f4ced48070a32a.zip
- Fix problem tath OpenSP.so is not linked with libosp.so
- Add missing dependency upon p5-Test-Exception. PR: ports143647 Submitted by: Yasuhiro KIMURA <yasu@utahime.org> Approved by: itetcu (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=250677
Diffstat (limited to 'textproc/p5-SGML-Parser-OpenSP')
-rw-r--r--textproc/p5-SGML-Parser-OpenSP/Makefile11
-rw-r--r--textproc/p5-SGML-Parser-OpenSP/files/patch-Makefile.PL13
2 files changed, 19 insertions, 5 deletions
diff --git a/textproc/p5-SGML-Parser-OpenSP/Makefile b/textproc/p5-SGML-Parser-OpenSP/Makefile
index 606c2df9a632..a926ae8e421c 100644
--- a/textproc/p5-SGML-Parser-OpenSP/Makefile
+++ b/textproc/p5-SGML-Parser-OpenSP/Makefile
@@ -7,7 +7,7 @@
PORTNAME= SGML-Parser-OpenSP
PORTVERSION= 0.994
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,14 +16,19 @@ MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= Parse SGML documents using OpenSP
BUILD_DEPENDS= onsgmls:${PORTSDIR}/textproc/opensp \
- p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_DOS2UNIX= yes
PERL_CONFIGURE= yes
CC= ${CXX}
-CONFIGURE_ARGS+="INC=-I${LOCALBASE}/include -I${LOCALBASE}/lib"
+CONFIGURE_ARGS+="INC=-I${LOCALBASE}/include"
MAN3= SGML::Parser::OpenSP.3 SGML::Parser::OpenSP::Tools.3
+post-patch:
+ (cd ${WRKSRC} ; \
+ ${REINPLACE_CMD} "s|%%LOCALBASE%%|${LOCALBASE}|g" Makefile.PL )
+
.include <bsd.port.mk>
diff --git a/textproc/p5-SGML-Parser-OpenSP/files/patch-Makefile.PL b/textproc/p5-SGML-Parser-OpenSP/files/patch-Makefile.PL
index 7811b2b55c16..202133ac48b1 100644
--- a/textproc/p5-SGML-Parser-OpenSP/files/patch-Makefile.PL
+++ b/textproc/p5-SGML-Parser-OpenSP/files/patch-Makefile.PL
@@ -1,5 +1,14 @@
---- Makefile.PL.orig 2007-07-29 03:05:27.000000000 +0800
-+++ Makefile.PL 2007-07-29 03:06:38.000000000 +0800
+--- Makefile.PL.orig 2010-02-07 23:33:39.000000000 +0900
++++ Makefile.PL 2010-02-07 23:34:03.000000000 +0900
+@@ -15,7 +15,7 @@
+ # assume some compatible Linux
+ $options{LD} = "g++";
+ $options{CC} = "g++";
+- $options{LIBS} = "-lstdc++ -losp";
++ $options{LIBS} = "-L%%LOCALBASE%%/lib -lstdc++ -losp";
+ }
+
+ WriteMakefile(
@@ -26,6 +26,10 @@
Test::Exception => 0,
File::Temp => 0,