aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Spreadsheet-WriteExcel
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2013-11-07 03:52:41 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2013-11-07 03:52:41 +0000
commitfb2d5da4ebc1084c623330fb16bdcba15bb94569 (patch)
tree36786afbdfb0f0368eaca996fb006935240c6493 /textproc/p5-Spreadsheet-WriteExcel
parent641aebe3adc2c952a71a943fa648da6f4daf0b14 (diff)
downloadports-fb2d5da4ebc1084c623330fb16bdcba15bb94569.tar.gz
ports-fb2d5da4ebc1084c623330fb16bdcba15bb94569.zip
Support STAGEDIR.
Notes
Notes: svn path=/head/; revision=333056
Diffstat (limited to 'textproc/p5-Spreadsheet-WriteExcel')
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/Makefile41
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/pkg-plist225
2 files changed, 132 insertions, 134 deletions
diff --git a/textproc/p5-Spreadsheet-WriteExcel/Makefile b/textproc/p5-Spreadsheet-WriteExcel/Makefile
index ff589cb6aca0..a22baa01960a 100644
--- a/textproc/p5-Spreadsheet-WriteExcel/Makefile
+++ b/textproc/p5-Spreadsheet-WriteExcel/Makefile
@@ -21,43 +21,20 @@ USE_PERL5= configure
USE_DOS2UNIX= yes
DOS2UNIX_REGEX= "*.p[lm]"
-MAN1= chartex.1
-MAN3= Spreadsheet::WriteExcel.3 \
- Spreadsheet::WriteExcel::BIFFwriter.3 \
- Spreadsheet::WriteExcel::Big.3 \
- Spreadsheet::WriteExcel::Chart.3 \
- Spreadsheet::WriteExcel::Chart::Area.3 \
- Spreadsheet::WriteExcel::Chart::Bar.3 \
- Spreadsheet::WriteExcel::Chart::Column.3 \
- Spreadsheet::WriteExcel::Chart::External.3 \
- Spreadsheet::WriteExcel::Chart::Line.3 \
- Spreadsheet::WriteExcel::Chart::Pie.3 \
- Spreadsheet::WriteExcel::Chart::Scatter.3 \
- Spreadsheet::WriteExcel::Chart::Stock.3 \
- Spreadsheet::WriteExcel::Examples.3 \
- Spreadsheet::WriteExcel::Format.3 \
- Spreadsheet::WriteExcel::Formula.3 \
- Spreadsheet::WriteExcel::OLEwriter.3 \
- Spreadsheet::WriteExcel::Properties.3 \
- Spreadsheet::WriteExcel::Utility.3 \
- Spreadsheet::WriteExcel::Workbook.3 \
- Spreadsheet::WriteExcel::Worksheet.3
-
-NO_STAGE= yes
post-install:
.ifndef(NOPORTDOCS)
@${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
- @${MKDIR} ${DOCSDIR}/images
- @${MKDIR} ${DOCSDIR}/tpj_images
- ${INSTALL_DATA} ${WRKSRC}/docs/*.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/images/* ${DOCSDIR}/images
- ${INSTALL_DATA} ${WRKSRC}/docs/tpj_images/* ${DOCSDIR}/tpj_images
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/images
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/tpj_images
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.html ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/images/* ${STAGEDIR}${DOCSDIR}/images
+ ${INSTALL_DATA} ${WRKSRC}/docs/tpj_images/* ${STAGEDIR}${DOCSDIR}/tpj_images
@${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/README \
- ${WRKSRC}/examples/republic.png ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/*.pl ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/examples/*.txt ${EXAMPLESDIR}
+ ${WRKSRC}/examples/republic.png ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/*.pl ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/*.txt ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/textproc/p5-Spreadsheet-WriteExcel/pkg-plist b/textproc/p5-Spreadsheet-WriteExcel/pkg-plist
index 0b39fa21e96f..52551ab42675 100644
--- a/textproc/p5-Spreadsheet-WriteExcel/pkg-plist
+++ b/textproc/p5-Spreadsheet-WriteExcel/pkg-plist
@@ -1,3 +1,24 @@
+bin/chartex
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::BIFFwriter.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Big.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Chart.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Chart::Area.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Chart::Bar.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Chart::Column.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Chart::External.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Chart::Line.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Chart::Pie.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Chart::Scatter.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Chart::Stock.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Examples.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Format.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Formula.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::OLEwriter.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Properties.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Utility.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Workbook.3.gz
+%%PERL5_MAN3%%/Spreadsheet::WriteExcel::Worksheet.3.gz
%%SITE_PERL%%/Spreadsheet/WriteExcel.pm
%%SITE_PERL%%/Spreadsheet/WriteExcel/BIFFwriter.pm
%%SITE_PERL%%/Spreadsheet/WriteExcel/Big.pm
@@ -19,7 +40,7 @@
%%SITE_PERL%%/Spreadsheet/WriteExcel/Workbook.pm
%%SITE_PERL%%/Spreadsheet/WriteExcel/Worksheet.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spreadsheet/WriteExcel/.packlist
-bin/chartex
+man/man1/chartex.1.gz
%%PORTDOCS%%%%DOCSDIR%%/Perl_Journal_Article.html
%%PORTDOCS%%%%DOCSDIR%%/images/example.jpg
%%PORTDOCS%%%%DOCSDIR%%/images/swe.png
@@ -32,109 +53,109 @@ bin/chartex
%%PORTDOCS%%%%DOCSDIR%%/tpj_images/tpj0503-0004-03.gif
%%PORTDOCS%%%%DOCSDIR%%/tpj_images/tpj0503-0004-04.gif
%%PORTDOCS%%%%DOCSDIR%%/tpj_images/tpj0503-0004-05.gif
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/a_simple.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/autofilter.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/autofit.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bigfile.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bug_report.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cgi.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chart_area.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chart_bar.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chart_column.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chart_line.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chart_pie.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chart_scatter.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chart_stock.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chess.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/colors.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comments1.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comments2.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/convertA1.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/copyformat.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/csv2xls.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/data_validate.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/date_time.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datecalc1.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/datecalc2.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/defined_name.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/diag_border.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/easter_egg.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/filehandle.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/formats.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/formula_result.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/function_locale.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gen_examples_pod.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/headers.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hide_sheet.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hyperlink1.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hyperlink2.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/images.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/indent.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lecxe.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/merge1.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/merge2.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/merge3.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/merge4.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/merge5.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/merge6.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mod_perl1.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mod_perl2.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/outline.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/outline_collapsed.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/panes.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/properties.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/protection.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regions.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/repeat.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/republic.png
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/right_to_left.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/row_wrap.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sales.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sendmail.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stats.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stats_ext.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stocks.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tab_colors.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tab2xls.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/textwrap.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_2022_jp.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_2022_jp.txt
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_8859_11.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_8859_11.txt
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_8859_7.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_8859_7.txt
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_big5.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_big5.txt
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_cp1251.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_cp1251.txt
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_cp1256.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_cp1256.txt
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_cyrillic.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_koi8r.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_koi8r.txt
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_list.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_polish_utf8.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_polish_utf8.txt
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_shift_jis.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_shift_jis.txt
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_utf16.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/unicode_utf16_japan.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/win32ole.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/writeA1.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write_arrays.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write_handler1.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write_handler2.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write_handler3.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write_handler4.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%%%EXAMPLESDIR%%/write_to_scalar.pl
-%%PORTDOCS%%%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/a_simple.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/autofilter.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/autofit.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/bigfile.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/bug_report.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/cgi.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/chart_area.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/chart_bar.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/chart_column.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/chart_line.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/chart_pie.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/chart_scatter.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/chart_stock.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/chess.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/colors.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/comments1.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/comments2.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/convertA1.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/copyformat.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/csv2xls.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/data_validate.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/date_time.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/datecalc1.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/datecalc2.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/defined_name.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/demo.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/diag_border.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/easter_egg.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/filehandle.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/formats.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/formula_result.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/function_locale.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/gen_examples_pod.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/headers.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/hide_sheet.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/hyperlink1.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/hyperlink2.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/images.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/indent.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/lecxe.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/merge1.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/merge2.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/merge3.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/merge4.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/merge5.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/merge6.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/mod_perl1.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/mod_perl2.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/outline.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/outline_collapsed.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/panes.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/properties.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/protection.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/regions.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/repeat.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/republic.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/right_to_left.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/row_wrap.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/sendmail.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/stats.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/stats_ext.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/stocks.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/tab2xls.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/tab_colors.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/textwrap.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_2022_jp.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_2022_jp.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_8859_11.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_8859_11.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_8859_7.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_8859_7.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_big5.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_big5.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_cp1251.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_cp1251.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_cp1256.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_cp1256.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_cyrillic.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_koi8r.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_koi8r.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_list.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_polish_utf8.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_polish_utf8.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_shift_jis.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_shift_jis.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_utf16.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/unicode_utf16_japan.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/win32ole.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/writeA1.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/write_arrays.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/write_handler1.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/write_handler2.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/write_handler3.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/write_handler4.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/write_to_scalar.pl
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/tpj_images
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Spreadsheet/WriteExcel
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Spreadsheet/WriteExcel
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Spreadsheet
-@dirrm %%SITE_PERL%%/Spreadsheet/WriteExcel/Chart
-@dirrm %%SITE_PERL%%/Spreadsheet/WriteExcel
+@dirrmtry %%SITE_PERL%%/Spreadsheet/WriteExcel/Chart
+@dirrmtry %%SITE_PERL%%/Spreadsheet/WriteExcel
@dirrmtry %%SITE_PERL%%/Spreadsheet