aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-String-ShowDiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-29 06:51:02 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-29 06:51:02 +0000
commit0d9e646092caa5531228f24f6345da2ac84bbf47 (patch)
tree5b238d9be93a009155e4711bd5e36efc0c179e34 /textproc/p5-String-ShowDiff
parent5bc16c875d768d04bcf1a393b07a65985628719c (diff)
downloadports-0d9e646092caa5531228f24f6345da2ac84bbf47.tar.gz
ports-0d9e646092caa5531228f24f6345da2ac84bbf47.zip
NEW PORT devel/p5-String-ShowDiff
This module is a wrapper around the diff algorithm from the module Algorithm::Diff. It's job is to simplify a visualization of the differences of each strings. Compared to the many other Diff modules, the output is neither in diff-style nor are the recognised differences on line or word boundaries, they are at character level. PR: ports/51434 Submitted by: Mathieu Arnold <m@absolight.net>
Notes
Notes: svn path=/head/; revision=79849
Diffstat (limited to 'textproc/p5-String-ShowDiff')
-rw-r--r--textproc/p5-String-ShowDiff/Makefile31
-rw-r--r--textproc/p5-String-ShowDiff/distinfo1
-rw-r--r--textproc/p5-String-ShowDiff/pkg-descr9
-rw-r--r--textproc/p5-String-ShowDiff/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/textproc/p5-String-ShowDiff/Makefile b/textproc/p5-String-ShowDiff/Makefile
new file mode 100644
index 000000000000..d864a337132c
--- /dev/null
+++ b/textproc/p5-String-ShowDiff/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-String-ShowDiff
+# Date created: April 26, 2003
+# Whom: Mathieu Arnold <m@absolight.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-ShowDiff
+PORTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= String
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m@absolight.net
+COMMENT= Perl extension to help visualize differences between strings
+
+BUILD_DEPENDS= ${SITE_PERL}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff \
+ ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= String::ShowDiff.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-String-ShowDiff/distinfo b/textproc/p5-String-ShowDiff/distinfo
new file mode 100644
index 000000000000..3c6ecc133a8f
--- /dev/null
+++ b/textproc/p5-String-ShowDiff/distinfo
@@ -0,0 +1 @@
+MD5 (String-ShowDiff-0.01.tar.gz) = 7530e84082cd957b3a50b31dd8b94c9a
diff --git a/textproc/p5-String-ShowDiff/pkg-descr b/textproc/p5-String-ShowDiff/pkg-descr
new file mode 100644
index 000000000000..1de77804401b
--- /dev/null
+++ b/textproc/p5-String-ShowDiff/pkg-descr
@@ -0,0 +1,9 @@
+This module is a wrapper around the diff algorithm from the module
+Algorithm::Diff. It's job is to simplify a visualization of the differences of
+each strings.
+
+Compared to the many other Diff modules, the output is neither in diff-style
+nor are the recognised differences on line or word boundaries, they are at
+character level.
+
+WWW: http://search.cpan.org/author/BIGJ/String-ShowDiff/
diff --git a/textproc/p5-String-ShowDiff/pkg-plist b/textproc/p5-String-ShowDiff/pkg-plist
new file mode 100644
index 000000000000..d7fcf9d93265
--- /dev/null
+++ b/textproc/p5-String-ShowDiff/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/String/ShowDiff.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/ShowDiff/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String/ShowDiff/
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/String
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/String