aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Term-QRCode
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2012-04-21 16:21:00 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2012-04-21 16:21:00 +0000
commit8c05006f36323cec6c707fa8def60284d720de50 (patch)
treea10456c043605907c4001f77c48605a792683b4c /textproc/p5-Term-QRCode
parent420b8466e0faba63e7cad82d913d51ae01b8bc93 (diff)
downloadports-8c05006f36323cec6c707fa8def60284d720de50.tar.gz
ports-8c05006f36323cec6c707fa8def60284d720de50.zip
Add p5-Term-QRCode 0.01, generate QR Code on Terminal.
PR: ports/166574 Submitted by: Stephon Chen <stephon@gmail.com>
Notes
Notes: svn path=/head/; revision=295192
Diffstat (limited to 'textproc/p5-Term-QRCode')
-rw-r--r--textproc/p5-Term-QRCode/Makefile25
-rw-r--r--textproc/p5-Term-QRCode/distinfo2
-rw-r--r--textproc/p5-Term-QRCode/pkg-descr4
-rw-r--r--textproc/p5-Term-QRCode/pkg-plist8
4 files changed, 39 insertions, 0 deletions
diff --git a/textproc/p5-Term-QRCode/Makefile b/textproc/p5-Term-QRCode/Makefile
new file mode 100644
index 000000000000..762cdbefb0bd
--- /dev/null
+++ b/textproc/p5-Term-QRCode/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Term-QRCode
+# Date created: 2012/03/22
+# Whom: Stephon Chen <stephon@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Term-QRCode
+PORTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= stephon@gmail.com
+COMMENT= Generate QR Code on Terminal
+
+BUILD_DEPENDS= libqrencode>=2.0.0:${PORTSDIR}/graphics/libqrencode \
+ p5-Text-QRCode>0:${PORTSDIR}/textproc/p5-Text-QRCode
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Term::QRCode.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Term-QRCode/distinfo b/textproc/p5-Term-QRCode/distinfo
new file mode 100644
index 000000000000..ddcfd77933ea
--- /dev/null
+++ b/textproc/p5-Term-QRCode/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Term-QRCode-0.01.tar.gz) = 058d97dec9927df242baa2e8db6c37345f9747f3095369fba00e3771153f1079
+SIZE (Term-QRCode-0.01.tar.gz) = 36734
diff --git a/textproc/p5-Term-QRCode/pkg-descr b/textproc/p5-Term-QRCode/pkg-descr
new file mode 100644
index 000000000000..4727f4ba6a92
--- /dev/null
+++ b/textproc/p5-Term-QRCode/pkg-descr
@@ -0,0 +1,4 @@
+This module allows you to generate QR Code on Terminal. This module
+use libqrencode '2.0.0' and above.
+
+WWW: http://search.cpan.org/dist/Term-QRCode/
diff --git a/textproc/p5-Term-QRCode/pkg-plist b/textproc/p5-Term-QRCode/pkg-plist
new file mode 100644
index 000000000000..9266261719be
--- /dev/null
+++ b/textproc/p5-Term-QRCode/pkg-plist
@@ -0,0 +1,8 @@
+bin/term-qrcode
+%%SITE_PERL%%/Term/QRCode.pm
+%%SITE_PERL%%/mach/auto/Term/QRCode/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/Term/QRCode
+@dirrm %%SITE_PERL%%/mach/auto/Term
+@dirrm %%SITE_PERL%%/mach/auto
+@dirrm %%SITE_PERL%%/mach
+@dirrm %%SITE_PERL%%/Term