aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Diff/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2002-07-14 13:55:46 +0000
committerAnton Berezin <tobez@FreeBSD.org>2002-07-14 13:55:46 +0000
commitd6c57c4e61a225f1b2282e8bceff3e67da5e869b (patch)
tree9b711b3cf0a7e6b2b43a05fc738d304b947fc40e /textproc/p5-Text-Diff/Makefile
parent87308c0a1de979680591885bcefba0456071aaeb (diff)
downloadports-d6c57c4e61a225f1b2282e8bceff3e67da5e869b.tar.gz
ports-d6c57c4e61a225f1b2282e8bceff3e67da5e869b.zip
Add p5-Text-Diff, a perl module to perform diffs on files and record
sets.
Notes
Notes: svn path=/head/; revision=62925
Diffstat (limited to 'textproc/p5-Text-Diff/Makefile')
-rw-r--r--textproc/p5-Text-Diff/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/textproc/p5-Text-Diff/Makefile b/textproc/p5-Text-Diff/Makefile
new file mode 100644
index 000000000000..11a81208287e
--- /dev/null
+++ b/textproc/p5-Text-Diff/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: textproc/p5-Text-Diff
+# Date created: 14 July 2002
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Diff
+PORTVERSION= 0.34
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Algorithm/Diff.pm:${PORTSDIR}/devel/p5-Algorithm-Diff
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Diff.3 Text::Diff::Table.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>