aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-MultiMarkdown
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-10-23 02:59:15 +0000
committerWen Heping <wen@FreeBSD.org>2009-10-23 02:59:15 +0000
commit793a62517dd4fdf3172eda6e71f346ebfd83e808 (patch)
treefe559dd32115ea39abe89e8601fbfb336f766f93 /textproc/p5-Text-MultiMarkdown
parent6db5f581a58b7f398542704d42cefab016135958 (diff)
downloadports-793a62517dd4fdf3172eda6e71f346ebfd83e808.tar.gz
ports-793a62517dd4fdf3172eda6e71f346ebfd83e808.zip
Markdown is a text-to-HTML filter; it translates an easy-to-read and
easy-to-write structured text format into HTML. Markdown's text format is most similar to that of plain text email, and supports features such as headers, *emphasis*, code blocks, blockquotes, and links. Markdown's syntax is designed not as a generic markup language, but specifically to serve as a front-end to (X)HTML. You can use span-level HTML tags anywhere in a Markdown document, and you can use block level HTML tags (like <div> and <table> as well). Text::MultiMarkdown implements the MultiMarkdown markdown syntax extensions from: http://fletcherpenney.net/multimarkdown/ WWW: http://search.cpan.org/dist/Text-MultiMarkdown/ Approved by: mentors(implicit)
Notes
Notes: svn path=/head/; revision=243227
Diffstat (limited to 'textproc/p5-Text-MultiMarkdown')
-rw-r--r--textproc/p5-Text-MultiMarkdown/Makefile30
-rw-r--r--textproc/p5-Text-MultiMarkdown/distinfo3
-rw-r--r--textproc/p5-Text-MultiMarkdown/files/patch-MANIFEST11
-rw-r--r--textproc/p5-Text-MultiMarkdown/files/patch-Makefile.PL11
-rw-r--r--textproc/p5-Text-MultiMarkdown/pkg-descr14
-rw-r--r--textproc/p5-Text-MultiMarkdown/pkg-plist5
6 files changed, 74 insertions, 0 deletions
diff --git a/textproc/p5-Text-MultiMarkdown/Makefile b/textproc/p5-Text-MultiMarkdown/Makefile
new file mode 100644
index 000000000000..b74a830f9d44
--- /dev/null
+++ b/textproc/p5-Text-MultiMarkdown/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Text-MultiMarkdown
+# Date created: 23 Oct, 2009
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-MultiMarkdown
+PORTVERSION= 1.0.30
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Convert MultiMarkdown syntax to (X)HTML
+
+BUILD_DEPENDS= \
+ ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp \
+ ${SITE_PERL}/${PERL_ARCH}/List/MoreUtils.pm:${PORTSDIR}/lang/p5-List-MoreUtils \
+ ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Text-Markdown>=1.0.26:${PORTSDIR}/textproc/p5-Text-Markdown
+RUN_DEPENDS= \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Text-Markdown>=1.0.26:${PORTSDIR}/textproc/p5-Text-Markdown
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::MultiMarkdown.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-MultiMarkdown/distinfo b/textproc/p5-Text-MultiMarkdown/distinfo
new file mode 100644
index 000000000000..b4e66b5e69cc
--- /dev/null
+++ b/textproc/p5-Text-MultiMarkdown/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-MultiMarkdown-1.0.30.tar.gz) = 56acc2d9f8cb83ea11a640e877b5a3bf
+SHA256 (Text-MultiMarkdown-1.0.30.tar.gz) = 51d6f57cd8083d61c85bf4a46624affaeaa54faa76b1b53c0b1e3361bbcd1ace
+SIZE (Text-MultiMarkdown-1.0.30.tar.gz) = 94225
diff --git a/textproc/p5-Text-MultiMarkdown/files/patch-MANIFEST b/textproc/p5-Text-MultiMarkdown/files/patch-MANIFEST
new file mode 100644
index 000000000000..7c227cc211d8
--- /dev/null
+++ b/textproc/p5-Text-MultiMarkdown/files/patch-MANIFEST
@@ -0,0 +1,11 @@
+--- MANIFEST.orig 2009-10-23 10:26:10.000000000 +0800
++++ MANIFEST 2009-10-23 10:26:37.000000000 +0800
+@@ -163,8 +163,6 @@
+ t/docs-maruku-unittest/xml_instruction.text
+ t/docs-multimarkdown-todo/Amps_and_angle_encoding.html
+ t/docs-multimarkdown-todo/Amps_and_angle_encoding.text
+-t/docs-multimarkdown-todo/Citations.text
+-t/docs-multimarkdown-todo/Citations.xhtml
+ t/docs-multimarkdown-todo/Email_Obfuscation.html
+ t/docs-multimarkdown-todo/Email_Obfuscation.text
+ t/docs-multimarkdown-todo/Tidyness.html
diff --git a/textproc/p5-Text-MultiMarkdown/files/patch-Makefile.PL b/textproc/p5-Text-MultiMarkdown/files/patch-Makefile.PL
new file mode 100644
index 000000000000..ca8c5b786bd2
--- /dev/null
+++ b/textproc/p5-Text-MultiMarkdown/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig 2009-10-23 09:40:28.000000000 +0800
++++ Makefile.PL 2009-10-23 09:40:37.000000000 +0800
+@@ -26,7 +26,7 @@
+ }
+
+ # Scripts I install
+-prompt_script('script/MultiMarkdown.pl');
++#prompt_script('script/MultiMarkdown.pl');
+
+ WriteAll;
+
diff --git a/textproc/p5-Text-MultiMarkdown/pkg-descr b/textproc/p5-Text-MultiMarkdown/pkg-descr
new file mode 100644
index 000000000000..744d02743a65
--- /dev/null
+++ b/textproc/p5-Text-MultiMarkdown/pkg-descr
@@ -0,0 +1,14 @@
+Markdown is a text-to-HTML filter; it translates an easy-to-read and
+easy-to-write structured text format into HTML. Markdown's text format
+is most similar to that of plain text email, and supports features such
+as headers, *emphasis*, code blocks, blockquotes, and links.
+
+Markdown's syntax is designed not as a generic markup language, but
+specifically to serve as a front-end to (X)HTML. You can use span-level
+HTML tags anywhere in a Markdown document, and you can use block level
+HTML tags (like <div> and <table> as well).
+
+Text::MultiMarkdown implements the MultiMarkdown markdown syntax
+extensions from: http://fletcherpenney.net/multimarkdown/
+
+WWW: http://search.cpan.org/dist/Text-MultiMarkdown/
diff --git a/textproc/p5-Text-MultiMarkdown/pkg-plist b/textproc/p5-Text-MultiMarkdown/pkg-plist
new file mode 100644
index 000000000000..828f581b258c
--- /dev/null
+++ b/textproc/p5-Text-MultiMarkdown/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/MultiMarkdown/.packlist
+%%SITE_PERL%%/Text/MultiMarkdown.pm
+@dirrmtry %%SITE_PERL%%/Text
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/MultiMarkdown
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text