aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-RecordParser
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-12-04 16:27:16 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-12-04 16:27:16 +0000
commite077c454f190d40012bc202e965e9e6bd556a1e1 (patch)
tree6a748f2e531797cbf59d86cdbbd5d0f719bd03a2 /textproc/p5-Text-RecordParser
parentc4fc4242f6d480cfa6c2dceed30d83f0b1f4800f (diff)
downloadports-e077c454f190d40012bc202e965e9e6bd556a1e1.tar.gz
ports-e077c454f190d40012bc202e965e9e6bd556a1e1.zip
Add p5-Text-RecordParser 0.04, read record-oriented files.
PR: 59623 Submitted by: Lars Thegler <lars@thegler.dk>
Notes
Notes: svn path=/head/; revision=95025
Diffstat (limited to 'textproc/p5-Text-RecordParser')
-rw-r--r--textproc/p5-Text-RecordParser/Makefile30
-rw-r--r--textproc/p5-Text-RecordParser/distinfo1
-rw-r--r--textproc/p5-Text-RecordParser/pkg-descr6
-rw-r--r--textproc/p5-Text-RecordParser/pkg-plist5
4 files changed, 42 insertions, 0 deletions
diff --git a/textproc/p5-Text-RecordParser/Makefile b/textproc/p5-Text-RecordParser/Makefile
new file mode 100644
index 000000000000..da12139e7096
--- /dev/null
+++ b/textproc/p5-Text-RecordParser/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Text-RecordParser
+# Date created: Nov 23 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+
+PORTNAME= Text-RecordParser
+PORTVERSION= 0.04
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= Read record-oriented files
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::RecordParser.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= "requires perl 5.6.x or later. Install lang/perl5 and try again"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-RecordParser/distinfo b/textproc/p5-Text-RecordParser/distinfo
new file mode 100644
index 000000000000..a89d781c7d8b
--- /dev/null
+++ b/textproc/p5-Text-RecordParser/distinfo
@@ -0,0 +1 @@
+MD5 (Text-RecordParser-0.04.tar.gz) = da8052da1a9768e9a8a1619af21c2790
diff --git a/textproc/p5-Text-RecordParser/pkg-descr b/textproc/p5-Text-RecordParser/pkg-descr
new file mode 100644
index 000000000000..6c323ec150a7
--- /dev/null
+++ b/textproc/p5-Text-RecordParser/pkg-descr
@@ -0,0 +1,6 @@
+This module is for reading record-oriented data. The most common example have
+records separated by newlines and fields separated by commas or tabs, but this
+module aims to provide a consistent interface for handling sequential records
+in a file however they may be delimited.
+
+WWW: http://search.cpan.org/dist/Text-RecordParser
diff --git a/textproc/p5-Text-RecordParser/pkg-plist b/textproc/p5-Text-RecordParser/pkg-plist
new file mode 100644
index 000000000000..f7e65f869c27
--- /dev/null
+++ b/textproc/p5-Text-RecordParser/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Text/RecordParser.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/RecordParser/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/RecordParser
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Text 2>/dev/null || true