aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-UML-Sequence/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2003-10-17 07:42:57 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2003-10-17 07:42:57 +0000
commit44bb04370f3aefc27b76049d9da6345dceb58add (patch)
treefef7ce42e1cd3840e5f40662e8333594d6d8bad5 /textproc/p5-UML-Sequence/Makefile
parent30881f8b636987d9dd2dc66fd39aff447443d2d1 (diff)
downloadports-44bb04370f3aefc27b76049d9da6345dceb58add.tar.gz
ports-44bb04370f3aefc27b76049d9da6345dceb58add.zip
Add p5-UML-Sequence 0.05,
a perl module that produce UML sequence diagrams. PR: 58067 Submitted by: Cheng-Lung Sung <clsung@dragon2.net>
Notes
Notes: svn path=/head/; revision=91487
Diffstat (limited to 'textproc/p5-UML-Sequence/Makefile')
-rw-r--r--textproc/p5-UML-Sequence/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/textproc/p5-UML-Sequence/Makefile b/textproc/p5-UML-Sequence/Makefile
new file mode 100644
index 000000000000..629a279cf261
--- /dev/null
+++ b/textproc/p5-UML-Sequence/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-UML-Sequence
+# Date created: October 15th 2003
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= UML-Sequence
+PORTVERSION= 0.05
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= UML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= A perl module that produce UML sequence diagrams
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= UML::Sequence.3 \
+ UML::Sequence::SimpleSeq.3 \
+ UML::Sequence::Activation.3 \
+ UML::seq2svg.3 \
+ UML::Sequence::PerlSeq.3 \
+ UML::Sequence::JavaSeq.3 \
+ UML::genericseq.3 \
+ Devel::OOCallSeq.3 \
+ UML::Sequence::PerlOOSeq.3 \
+ UML::Sequence::Svg.3 \
+ Devel::CallSeq.3
+
+.include <bsd.port.mk>