aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Elemental
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-10-13 07:48:22 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-10-13 07:48:22 +0000
commitb9af4efef7308dc84bdaaee5b6d80434dea68f8b (patch)
treeed5af1363b45c0082c0dfc411edaeeb16d638fd4 /textproc/p5-XML-Elemental
parentcd49748b40cfc21300eaaa8f189b41811b6f18a6 (diff)
downloadports-b9af4efef7308dc84bdaaee5b6d80434dea68f8b.tar.gz
ports-b9af4efef7308dc84bdaaee5b6d80434dea68f8b.zip
Add p5-XML-Elemental, an XML::Parser style and generic classes package
for simplistic and perlish handling of XML data
Notes
Notes: svn path=/head/; revision=119162
Diffstat (limited to 'textproc/p5-XML-Elemental')
-rw-r--r--textproc/p5-XML-Elemental/Makefile25
-rw-r--r--textproc/p5-XML-Elemental/distinfo2
-rw-r--r--textproc/p5-XML-Elemental/pkg-descr5
-rw-r--r--textproc/p5-XML-Elemental/pkg-plist9
4 files changed, 41 insertions, 0 deletions
diff --git a/textproc/p5-XML-Elemental/Makefile b/textproc/p5-XML-Elemental/Makefile
new file mode 100644
index 000000000000..883059ce01b0
--- /dev/null
+++ b/textproc/p5-XML-Elemental/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-XML-Elemental
+# Date created: 2004-10-11
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= XML-Elemental
+PORTVERSION= 1.03
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Generic classes for simplistic and perlish handling of XML data
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Parser::Style::Elemental.3 XML::Elemental::Node.3 \
+ XML::Elemental::Element.3 XML::Elemental::Characters.3 \
+ XML::Elemental::Document.3 XML::Elemental.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Elemental/distinfo b/textproc/p5-XML-Elemental/distinfo
new file mode 100644
index 000000000000..56628cecbd05
--- /dev/null
+++ b/textproc/p5-XML-Elemental/distinfo
@@ -0,0 +1,2 @@
+MD5 (XML-Elemental-1.03.tar.gz) = 1320e9848c5d65fc45789ec7eed0d3c8
+SIZE (XML-Elemental-1.03.tar.gz) = 6001
diff --git a/textproc/p5-XML-Elemental/pkg-descr b/textproc/p5-XML-Elemental/pkg-descr
new file mode 100644
index 000000000000..b7b07b78337d
--- /dev/null
+++ b/textproc/p5-XML-Elemental/pkg-descr
@@ -0,0 +1,5 @@
+XML::Elemental is an XML::Parser style and generic classes package
+for simplistic and perlish handling of XML data.
+
+WWW: http://search.cpan.org/~tima/XML-Elemental/
+Author: Timothy Appnel
diff --git a/textproc/p5-XML-Elemental/pkg-plist b/textproc/p5-XML-Elemental/pkg-plist
new file mode 100644
index 000000000000..d0deccde4825
--- /dev/null
+++ b/textproc/p5-XML-Elemental/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/XML/Elemental.pm
+%%SITE_PERL%%/XML/Parser/Style/Elemental.pm
+%%SITE_PERL%%/XML/Elemental/Element.pm
+%%SITE_PERL%%/XML/Elemental/Node.pm
+%%SITE_PERL%%/XML/Elemental/Characters.pm
+%%SITE_PERL%%/XML/Elemental/Document.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Elemental/.packlist
+@dirrm %%SITE_PERL%%/XML/Elemental
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Elemental