aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-Elemental
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-11-20 12:59:08 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-11-20 12:59:08 +0000
commitfa1f080d72961d131294ba770073868a76766de8 (patch)
tree4864f03acf3d9564fba93d1c489e5cec5cb2b627 /textproc/p5-XML-Elemental
parent1913e1fa13c2ef775ee49e4d9813f7565cf71590 (diff)
downloadports-fa1f080d72961d131294ba770073868a76766de8.tar.gz
ports-fa1f080d72961d131294ba770073868a76766de8.zip
Update to 2.0; assign maintainer to perl@; require perl from ports.
Notes
Notes: svn path=/head/; revision=148848
Diffstat (limited to 'textproc/p5-XML-Elemental')
-rw-r--r--textproc/p5-XML-Elemental/Makefile26
-rw-r--r--textproc/p5-XML-Elemental/distinfo5
-rw-r--r--textproc/p5-XML-Elemental/pkg-plist12
3 files changed, 29 insertions, 14 deletions
diff --git a/textproc/p5-XML-Elemental/Makefile b/textproc/p5-XML-Elemental/Makefile
index ece31f810a6b..a418e98c7bcb 100644
--- a/textproc/p5-XML-Elemental/Makefile
+++ b/textproc/p5-XML-Elemental/Makefile
@@ -5,22 +5,34 @@
# $FreeBSD$
PORTNAME= XML-Elemental
-PORTVERSION= 1.03
+PORTVERSION= 2.0
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Generic classes for simplistic and perlish handling of XML data
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= ${SITE_PERL}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN3= XML::Parser::Style::Elemental.3 XML::Elemental::Node.3 \
- XML::Elemental::Element.3 XML::Elemental::Characters.3 \
- XML::Elemental::Document.3 XML::Elemental.3
+MAN3= XML::Elemental.3 \
+ XML::Elemental::Characters.3 \
+ XML::Elemental::Document.3 \
+ XML::Elemental::Element.3 \
+ XML::Elemental::Node.3 \
+ XML::Elemental::SAXHandler.3 \
+ XML::Elemental::Util.3 \
+ XML::Parser::Style::Elemental.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-Elemental/distinfo b/textproc/p5-XML-Elemental/distinfo
index 56628cecbd05..fffab185cdc3 100644
--- a/textproc/p5-XML-Elemental/distinfo
+++ b/textproc/p5-XML-Elemental/distinfo
@@ -1,2 +1,3 @@
-MD5 (XML-Elemental-1.03.tar.gz) = 1320e9848c5d65fc45789ec7eed0d3c8
-SIZE (XML-Elemental-1.03.tar.gz) = 6001
+MD5 (XML-Elemental-2.0.tar.gz) = 209a5159b6a15790763bfe642af9a6d0
+SHA256 (XML-Elemental-2.0.tar.gz) = 69bc7ac57989ad0ff152b6c4ddd9263551afae3bbe2250d5d4573b1c801bc414
+SIZE (XML-Elemental-2.0.tar.gz) = 7888
diff --git a/textproc/p5-XML-Elemental/pkg-plist b/textproc/p5-XML-Elemental/pkg-plist
index a2dd1658a403..c6c7235b8233 100644
--- a/textproc/p5-XML-Elemental/pkg-plist
+++ b/textproc/p5-XML-Elemental/pkg-plist
@@ -1,12 +1,14 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Elemental/.packlist
%%SITE_PERL%%/XML/Elemental.pm
-%%SITE_PERL%%/XML/Parser/Style/Elemental.pm
-%%SITE_PERL%%/XML/Elemental/Element.pm
-%%SITE_PERL%%/XML/Elemental/Node.pm
%%SITE_PERL%%/XML/Elemental/Characters.pm
%%SITE_PERL%%/XML/Elemental/Document.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Elemental/.packlist
+%%SITE_PERL%%/XML/Elemental/Element.pm
+%%SITE_PERL%%/XML/Elemental/Node.pm
+%%SITE_PERL%%/XML/Elemental/SAXHandler.pm
+%%SITE_PERL%%/XML/Elemental/Util.pm
+%%SITE_PERL%%/XML/Parser/Style/Elemental.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Elemental
@dirrm %%SITE_PERL%%/XML/Parser/Style
@dirrm %%SITE_PERL%%/XML/Parser
@dirrm %%SITE_PERL%%/XML/Elemental
@unexec rmdir %D/%%SITE_PERL%%/XML 2>/dev/null || true
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Elemental