aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-LibRSVG/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-11-24 19:06:36 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-11-24 19:06:36 +0000
commit4c5e26eb618d46333e42d3ae4e6efdd26603a306 (patch)
tree4f346ddfa440d30d5d576d866c537addce048aaa /textproc/p5-XML-LibRSVG/Makefile
parent7f99924f6f7ebdc6e08adbfde401c0858e72a499 (diff)
downloadports-4c5e26eb618d46333e42d3ae4e6efdd26603a306.tar.gz
ports-4c5e26eb618d46333e42d3ae4e6efdd26603a306.zip
Add p5-XML-LibRSVG-0.01, an interface to GNOME's librsvg
PR: 32143 Submitted by: Sergey Skvortsov <skv@protey.ru>
Notes
Notes: svn path=/head/; revision=50492
Diffstat (limited to 'textproc/p5-XML-LibRSVG/Makefile')
-rw-r--r--textproc/p5-XML-LibRSVG/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/p5-XML-LibRSVG/Makefile b/textproc/p5-XML-LibRSVG/Makefile
new file mode 100644
index 000000000000..3bf7c1943994
--- /dev/null
+++ b/textproc/p5-XML-LibRSVG/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: XML::LibRSVG
+# Date created: 20 Nov 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-LibRSVG
+PORTVERSION= 0.01
+CATEGORIES= textproc graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+LIB_DEPENDS= rsvg.1:${PORTSDIR}/graphics/librsvg \
+ freetype.7:${PORTSDIR}/print/freetype2 \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ png.5:${PORTSDIR}/graphics/png \
+ art_lgpl.5:${PORTSDIR}/graphics/libart
+
+PERL_CONFIGURE= yes
+CONFIGURE_ENV= INC='-I${LOCALBASE}/include' LIBS='-L${LOCALBASE}/lib'
+USE_GTK= yes
+
+MAN3= XML::LibRSVG.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>