aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-LibXML-Simple
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:02:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-23 09:02:29 +0000
commitba35815b204304c771400df4ff4e6de95040d457 (patch)
treebd47b1fc0702f061cab094b8259b91c00a85074a /textproc/p5-XML-LibXML-Simple
parent015ce997c2f0171a19bbbbe6e003386fc8475fb3 (diff)
downloadports-ba35815b204304c771400df4ff4e6de95040d457.tar.gz
ports-ba35815b204304c771400df4ff4e6de95040d457.zip
This module is a blunt rewrite of XML::Simple (by Grant McLean)
to use the XML::LibXML parser for XML structures, where the original uses plain Perl or SAX parsers. WWW: http://http://search.cpan.org/dist/XML-LibXML-Simple/ PR: ports/133875 Submitted by: TERAMOTO Masahiro <markun at onohara.to>
Notes
Notes: svn path=/head/; revision=232555
Diffstat (limited to 'textproc/p5-XML-LibXML-Simple')
-rw-r--r--textproc/p5-XML-LibXML-Simple/Makefile26
-rw-r--r--textproc/p5-XML-LibXML-Simple/distinfo3
-rw-r--r--textproc/p5-XML-LibXML-Simple/pkg-descr5
-rw-r--r--textproc/p5-XML-LibXML-Simple/pkg-plist9
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/p5-XML-LibXML-Simple/Makefile b/textproc/p5-XML-LibXML-Simple/Makefile
new file mode 100644
index 000000000000..5abc5f89e32b
--- /dev/null
+++ b/textproc/p5-XML-LibXML-Simple/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-XML-LibXML-Simple
+# Date created: 2009-04-21
+# Whom: TERAMOTO Masahiro <markun@onohara.to>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-LibXML-Simple
+PORTVERSION= 0.13
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= markun@onohara.to
+COMMENT= XML::LibXML clone of XML::Simple::XMLin()
+
+BUILD_DEPENDS= p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Test-Pod>=1.00:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-XML-LibXML>=1.64:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::LibXML::Simple.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-LibXML-Simple/distinfo b/textproc/p5-XML-LibXML-Simple/distinfo
new file mode 100644
index 000000000000..49c297beaa16
--- /dev/null
+++ b/textproc/p5-XML-LibXML-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-LibXML-Simple-0.13.tar.gz) = b5175fb5a96b83b20ef0d291bb819391
+SHA256 (XML-LibXML-Simple-0.13.tar.gz) = 5001a0edc122d55aeeeea9624e6004d19a1a04a85e4d3f4fbeaf9f91df879941
+SIZE (XML-LibXML-Simple-0.13.tar.gz) = 19075
diff --git a/textproc/p5-XML-LibXML-Simple/pkg-descr b/textproc/p5-XML-LibXML-Simple/pkg-descr
new file mode 100644
index 000000000000..19ecfbb2291d
--- /dev/null
+++ b/textproc/p5-XML-LibXML-Simple/pkg-descr
@@ -0,0 +1,5 @@
+This module is a blunt rewrite of XML::Simple (by Grant McLean)
+to use the XML::LibXML parser for XML structures, where the original
+uses plain Perl or SAX parsers.
+
+WWW: http://http://search.cpan.org/dist/XML-LibXML-Simple/
diff --git a/textproc/p5-XML-LibXML-Simple/pkg-plist b/textproc/p5-XML-LibXML-Simple/pkg-plist
new file mode 100644
index 000000000000..310f0e082456
--- /dev/null
+++ b/textproc/p5-XML-LibXML-Simple/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/LibXML/Simple/.packlist
+%%SITE_PERL%%/XML/LibXML/Simple.pm
+%%SITE_PERL%%/XML/LibXML/Simple.pod
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/LibXML/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/LibXML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/LibXML
+@dirrmtry %%SITE_PERL%%/XML