aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-LibXML
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-12-20 14:20:32 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-12-20 14:20:32 +0000
commitc21fb45c65df2f8eed9a83900b78cf773a6f7f4e (patch)
treea452281099fed0477587f54b3e892694e2f2ceda /textproc/p5-XML-LibXML
parent712965fdf6b63e656fb683d250e3d93441a533de (diff)
downloadports-c21fb45c65df2f8eed9a83900b78cf773a6f7f4e.tar.gz
ports-c21fb45c65df2f8eed9a83900b78cf773a6f7f4e.zip
Update to 1.62001. Require perl from ports.
Approved by: maintainer
Notes
Notes: svn path=/head/; revision=180276
Diffstat (limited to 'textproc/p5-XML-LibXML')
-rw-r--r--textproc/p5-XML-LibXML/Makefile7
-rw-r--r--textproc/p5-XML-LibXML/distinfo6
-rw-r--r--textproc/p5-XML-LibXML/files/500503-patch-LibXML.xs22
3 files changed, 6 insertions, 29 deletions
diff --git a/textproc/p5-XML-LibXML/Makefile b/textproc/p5-XML-LibXML/Makefile
index 058a595f15d4..388dfefa8ccf 100644
--- a/textproc/p5-XML-LibXML/Makefile
+++ b/textproc/p5-XML-LibXML/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= XML-LibXML
-PORTVERSION= 1.62000
+PORTVERSION= 1.62001
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/0+$//}
MAINTAINER= skv@FreeBSD.org
COMMENT= Interface to Gnome libxml2 library
@@ -28,7 +27,7 @@ CONFIGURE_ENV= XMLPREFIX=${LOCALBASE}
PKGDEINSTALL= ${PKGINSTALL}
-WRKSRC= ${WRKDIR}/${DISTNAME}
+WRKSRC= ${WRKDIR}/${DISTNAME:C/00.$//}
MAN3= XML::LibXML.3 XML::LibXML::Attr.3 XML::LibXML::Boolean.3 \
XML::LibXML::CDATASection.3 XML::LibXML::Comment.3 \
@@ -49,7 +48,7 @@ post-install:
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-EXTRA_PATCHES= ${FILESDIR}/500503-*
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
.endif
.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-LibXML/distinfo b/textproc/p5-XML-LibXML/distinfo
index de37c96fe510..d8203300e79f 100644
--- a/textproc/p5-XML-LibXML/distinfo
+++ b/textproc/p5-XML-LibXML/distinfo
@@ -1,3 +1,3 @@
-MD5 (XML-LibXML-1.62.tar.gz) = 3aee3d539baac6fbb06e77b869e8a3b4
-SHA256 (XML-LibXML-1.62.tar.gz) = b8a87016c5849315585b3f2f21d205e07632a4ae6fa04484cf2d306d9392912c
-SIZE (XML-LibXML-1.62.tar.gz) = 230708
+MD5 (XML-LibXML-1.62001.tar.gz) = 01655a90b3f44e48efd486ac58c89cd6
+SHA256 (XML-LibXML-1.62001.tar.gz) = 2203d82e7df2d2a82d2776a5416f16c094f331542532006d6cbea77765c94c28
+SIZE (XML-LibXML-1.62001.tar.gz) = 230721
diff --git a/textproc/p5-XML-LibXML/files/500503-patch-LibXML.xs b/textproc/p5-XML-LibXML/files/500503-patch-LibXML.xs
deleted file mode 100644
index 982c5fa3ae4a..000000000000
--- a/textproc/p5-XML-LibXML/files/500503-patch-LibXML.xs
+++ /dev/null
@@ -1,22 +0,0 @@
---- LibXML.xs.orig Sat Aug 26 20:36:44 2006
-+++ LibXML.xs Tue Sep 5 21:30:37 2006
-@@ -74,6 +74,19 @@
- #define TEST_PERL_FLAG(flag) \
- SvTRUE(perl_get_sv(flag, FALSE)) ? 1 : 0
-
-+#ifndef SvPV_nolen
-+#define SvPV_nolen(sv) \
-+ ((SvFLAGS(sv) & (SVf_POK)) == SVf_POK \
-+ ? SvPVX(sv) : sv_2pv_nolen(sv))
-+
-+static char *
-+sv_2pv_nolen(register SV *sv)
-+{
-+ STRLEN n_a;
-+ return sv_2pv(sv, &n_a);
-+}
-+#endif
-+
- /* this should keep the default */
- static xmlExternalEntityLoader LibXML_old_ext_ent_loader = NULL;
-