aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-LibXSLT/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-06 12:52:10 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-06 12:52:10 +0000
commit655c86587ebe20214a339ed4d486ab69fe8b78f2 (patch)
tree4b363cde8fc5fc293d34fa011fba4b71f70cbd8f /textproc/p5-XML-LibXSLT/Makefile
parente555a1dbc30175363cba328548faa62c82a6db91 (diff)
downloadports-655c86587ebe20214a339ed4d486ab69fe8b78f2.tar.gz
ports-655c86587ebe20214a339ed4d486ab69fe8b78f2.zip
p5-XML-LibXSLT
A Perl interface to the GNOME XSLT library. PR: 27927 Submitted by: Dominic Mitchell <dom@happygiraffe.net>
Notes
Notes: svn path=/head/; revision=45875
Diffstat (limited to 'textproc/p5-XML-LibXSLT/Makefile')
-rw-r--r--textproc/p5-XML-LibXSLT/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/p5-XML-LibXSLT/Makefile b/textproc/p5-XML-LibXSLT/Makefile
new file mode 100644
index 000000000000..ae920087d849
--- /dev/null
+++ b/textproc/p5-XML-LibXSLT/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: XML::LibXSLT
+# Date created: 6 June 2001
+# Whom: Dom Mitchell <dom@happygiraffe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-LibXSLT
+PORTVERSION= 1.05
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dom@happygiraffe.net
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xslt.1:${PORTSDIR}/textproc/libxslt
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INC='-I${LOCALBASE}/include -I${LOCALBASE}/include/libxml2'
+
+MAN3= XML::LibXSLT.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>