aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-RAI/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2006-04-21 04:48:18 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2006-04-21 04:48:18 +0000
commit1c6b519fd4f716ccdcd1e61a4c809ff1a2de9eea (patch)
treec115e838e29a9fc49c74e66de4aa41047a37228c /textproc/p5-XML-RAI/Makefile
parent21687c1105299a2fe36b1e512bd8413e341ba409 (diff)
downloadports-1c6b519fd4f716ccdcd1e61a4c809ff1a2de9eea.tar.gz
ports-1c6b519fd4f716ccdcd1e61a4c809ff1a2de9eea.zip
- update to 1.301
- assign to perl@
Notes
Notes: svn path=/head/; revision=160053
Diffstat (limited to 'textproc/p5-XML-RAI/Makefile')
-rw-r--r--textproc/p5-XML-RAI/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/textproc/p5-XML-RAI/Makefile b/textproc/p5-XML-RAI/Makefile
index 0e52d4e1ea85..10a61ecb8378 100644
--- a/textproc/p5-XML-RAI/Makefile
+++ b/textproc/p5-XML-RAI/Makefile
@@ -5,25 +5,28 @@
# $FreeBSD$
PORTNAME= XML-RAI
-PORTVERSION= 1.21
+PORTVERSION= 1.3.01
PORTEPOCH= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/\.(..)$/\1/}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= RSS Abstraction Interface
-BUILD_DEPENDS= ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
- ${SITE_PERL}/XML/Elemental.pm:${PORTSDIR}/textproc/p5-XML-Elemental \
- ${SITE_PERL}/Class/XPath.pm:${PORTSDIR}/devel/p5-Class-XPath
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${SITE_PERL}/XML/RSS/Parser.pm:${PORTSDIR}/textproc/p5-XML-RSS-Parser \
+ ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PERL_CONFIGURE= yes
-MAN3= XML::RAI::Object.3 XML::RAI::Item.3 XML::RAI.3 XML::RAI::Image.3 \
- XML::RAI::Channel.3 XML::RSS::Parser::Element.3 XML::RSS::Parser.3 \
- XML::RSS::Parser::Characters.3 XML::RSS::Parser::Feed.3
+MAN3= XML::RAI.3 \
+ XML::RAI::Channel.3 \
+ XML::RAI::Image.3 \
+ XML::RAI::Item.3 \
+ XML::RAI::Object.3
.include <bsd.port.mk>