aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-RSS-JavaScript
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-10-31 09:47:09 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-10-31 09:47:09 +0000
commit0c7735bb865227ef3be7f87ad9d679bf9937b75a (patch)
tree408a2c939aadf5dd8e0dbd5b5d3dd49aa1b1ee9d /textproc/p5-XML-RSS-JavaScript
parentecc26d108eca8cff9d46bb810cbacc099554e63e (diff)
downloadports-0c7735bb865227ef3be7f87ad9d679bf9937b75a.tar.gz
ports-0c7735bb865227ef3be7f87ad9d679bf9937b75a.zip
Add p5-XML-RSS-JavaScript, it is a perl extension to serialize your RSS as
JavaScript
Notes
Notes: svn path=/head/; revision=92695
Diffstat (limited to 'textproc/p5-XML-RSS-JavaScript')
-rw-r--r--textproc/p5-XML-RSS-JavaScript/Makefile24
-rw-r--r--textproc/p5-XML-RSS-JavaScript/distinfo1
-rw-r--r--textproc/p5-XML-RSS-JavaScript/pkg-descr17
-rw-r--r--textproc/p5-XML-RSS-JavaScript/pkg-plist7
4 files changed, 49 insertions, 0 deletions
diff --git a/textproc/p5-XML-RSS-JavaScript/Makefile b/textproc/p5-XML-RSS-JavaScript/Makefile
new file mode 100644
index 000000000000..64795325ab22
--- /dev/null
+++ b/textproc/p5-XML-RSS-JavaScript/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-XML-RSS-JavaScript
+# Date created: 31 Oct 2003
+# Whom: Foxfair Hu <foxfair@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-RSS-JavaScript
+PORTVERSION= 0.3
+CATEGORIES= textproc www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Perl extension to serialize your RSS as JavaScript
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::RSS::JavaScript.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-RSS-JavaScript/distinfo b/textproc/p5-XML-RSS-JavaScript/distinfo
new file mode 100644
index 000000000000..511e4bda5790
--- /dev/null
+++ b/textproc/p5-XML-RSS-JavaScript/distinfo
@@ -0,0 +1 @@
+MD5 (XML-RSS-JavaScript-0.3.tar.gz) = aade78e577880b34578ac26e7269ddec
diff --git a/textproc/p5-XML-RSS-JavaScript/pkg-descr b/textproc/p5-XML-RSS-JavaScript/pkg-descr
new file mode 100644
index 000000000000..521f386a112f
--- /dev/null
+++ b/textproc/p5-XML-RSS-JavaScript/pkg-descr
@@ -0,0 +1,17 @@
+Serialize your RSS as JavaScript.
+
+Perhaps you use XML::RSS to generate RSS for consumption by RSS parsers.
+Perhaps you also get requests for how to use the RSS feed by people who
+have no idea how to parse XML, or write Perl programs for that matter.
+
+Enter XML::RSS::JavaScript, a simle subclass of XML::RSS which writes your
+RSS feed as a sequence of JavaScript print statements. This means you
+can then write the JavaScript to disk, and a users HTML can simple
+include it like so:
+
+ <script language="JavaScript" src="/myfeed.js"></script>
+
+What's more the javascript emits HTML that can be fully styled with
+CSS. See the CSS examples included with the distribution in the css directory.
+
+WWW: http://search.cpan.org/perldoc?XML::RSS::JavaScript
diff --git a/textproc/p5-XML-RSS-JavaScript/pkg-plist b/textproc/p5-XML-RSS-JavaScript/pkg-plist
new file mode 100644
index 000000000000..0dccc3b0c9be
--- /dev/null
+++ b/textproc/p5-XML-RSS-JavaScript/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/RSS/JavaScript/.packlist
+%%SITE_PERL%%/XML/RSS/JavaScript.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/RSS/JavaScript
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/RSS 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/XML/RSS 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/XML 2>/dev/null || true