aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-RSS-Parser
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2006-04-21 04:09:07 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2006-04-21 04:09:07 +0000
commit21687c1105299a2fe36b1e512bd8413e341ba409 (patch)
treeba543e604c27923ccf8d49a05e402d5594d86a62 /textproc/p5-XML-RSS-Parser
parent884b2f8e77510ab3cab2ed17f1fcfed9322c5eaa (diff)
downloadports-21687c1105299a2fe36b1e512bd8413e341ba409.tar.gz
ports-21687c1105299a2fe36b1e512bd8413e341ba409.zip
- add p5-XML-RSS-Parser 4.0
XML::RSS::Parser is a lightweight liberal parser of RSS feeds. This parser is "liberal" in that it does not demand compliance of a specific RSS version and will attempt to gracefully handle tags it does not expect or understand. The parser's only requirements is that the file is well-formed XML and remotely resembles RSS. Roughly speaking, well formed XML with a channel element as a direct sibling or the root tag and item elements etc. There are a number of advantages to using this module then just using a standard parser-tree combination. There are a number of different RSS formats in use today. In very subtle ways these formats are not entirely compatible from one to another. XML::RSS::Parser makes a couple assumptions to "normalize" the parse tree into a more consistent form. For instance, it forces channel and item into a parent-child relationship. WWW: http://search.cpan.org/dist/XML-RSS-Parser/
Notes
Notes: svn path=/head/; revision=160051
Diffstat (limited to 'textproc/p5-XML-RSS-Parser')
-rw-r--r--textproc/p5-XML-RSS-Parser/Makefile33
-rw-r--r--textproc/p5-XML-RSS-Parser/distinfo3
-rw-r--r--textproc/p5-XML-RSS-Parser/pkg-descr15
-rw-r--r--textproc/p5-XML-RSS-Parser/pkg-plist12
4 files changed, 63 insertions, 0 deletions
diff --git a/textproc/p5-XML-RSS-Parser/Makefile b/textproc/p5-XML-RSS-Parser/Makefile
new file mode 100644
index 000000000000..3d3ae476a060
--- /dev/null
+++ b/textproc/p5-XML-RSS-Parser/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-XML-RSS-Parser
+# Date created: 21 Apr 2006
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-RSS-Parser
+PORTVERSION= 4.0
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A liberal object-oriented parser for RSS feeds
+
+RUN_DEPENDS= ${SITE_PERL}/XML/Elemental.pm:${PORTSDIR}/textproc/p5-XML-Elemental \
+ ${SITE_PERL}/Class/XPath.pm:${PORTSDIR}/devel/p5-Class-XPath \
+ ${SITE_PERL}/Class/ErrorHandler.pm:${PORTSDIR}/devel/p5-Class-ErrorHandler
+BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+
+PERL_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.0//}
+
+MAN3= XML::RSS::Parser.3 \
+ XML::RSS::Parser::Characters.3 \
+ XML::RSS::Parser::Element.3 \
+ XML::RSS::Parser::Feed.3 \
+ XML::RSS::Parser::Util.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-RSS-Parser/distinfo b/textproc/p5-XML-RSS-Parser/distinfo
new file mode 100644
index 000000000000..f285d6101329
--- /dev/null
+++ b/textproc/p5-XML-RSS-Parser/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-RSS-Parser-4.0.tar.gz) = 5ffafdcb64edd843106f7a96efac4017
+SHA256 (XML-RSS-Parser-4.0.tar.gz) = b82e77384d41d5042c73376127f654dadb9651942d5ae371b11760c00f930767
+SIZE (XML-RSS-Parser-4.0.tar.gz) = 12744
diff --git a/textproc/p5-XML-RSS-Parser/pkg-descr b/textproc/p5-XML-RSS-Parser/pkg-descr
new file mode 100644
index 000000000000..3f5ad0b8bb13
--- /dev/null
+++ b/textproc/p5-XML-RSS-Parser/pkg-descr
@@ -0,0 +1,15 @@
+XML::RSS::Parser is a lightweight liberal parser of RSS feeds. This parser
+is "liberal" in that it does not demand compliance of a specific RSS version
+and will attempt to gracefully handle tags it does not expect or understand.
+The parser's only requirements is that the file is well-formed XML and
+remotely resembles RSS. Roughly speaking, well formed XML with a channel
+element as a direct sibling or the root tag and item elements etc.
+
+There are a number of advantages to using this module then just using
+a standard parser-tree combination. There are a number of different RSS
+formats in use today. In very subtle ways these formats are not entirely
+compatible from one to another. XML::RSS::Parser makes a couple assumptions
+to "normalize" the parse tree into a more consistent form. For instance,
+it forces channel and item into a parent-child relationship.
+
+WWW: http://search.cpan.org/dist/XML-RSS-Parser/
diff --git a/textproc/p5-XML-RSS-Parser/pkg-plist b/textproc/p5-XML-RSS-Parser/pkg-plist
new file mode 100644
index 000000000000..0ef7f7291e91
--- /dev/null
+++ b/textproc/p5-XML-RSS-Parser/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/XML/RSS/Parser.pm
+%%SITE_PERL%%/XML/RSS/Parser/Characters.pm
+%%SITE_PERL%%/XML/RSS/Parser/Element.pm
+%%SITE_PERL%%/XML/RSS/Parser/Feed.pm
+%%SITE_PERL%%/XML/RSS/Parser/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/RSS/Parser/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/RSS/Parser
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/RSS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/RSS/Parser
+@dirrmtry %%SITE_PERL%%/XML/RSS
+@dirrmtry %%SITE_PERL%%/XML