aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-SAX-Machines
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-12-29 17:20:00 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-12-29 17:20:00 +0000
commita57f22e3ab0bc81722153743869d9ec4cf343fa2 (patch)
tree862aaa25f8e6d94648fbca5fec295ee8ba5bd8b6 /textproc/p5-XML-SAX-Machines
parentb907e141c0dee7b901f9b865e4b62b19515e6955 (diff)
downloadports-a57f22e3ab0bc81722153743869d9ec4cf343fa2.tar.gz
ports-a57f22e3ab0bc81722153743869d9ec4cf343fa2.zip
Fix packaging on broken ExtUtils::MakeMaker
Notes
Notes: svn path=/head/; revision=125447
Diffstat (limited to 'textproc/p5-XML-SAX-Machines')
-rw-r--r--textproc/p5-XML-SAX-Machines/Makefile8
-rw-r--r--textproc/p5-XML-SAX-Machines/files/500503-Makefile.PL12
2 files changed, 19 insertions, 1 deletions
diff --git a/textproc/p5-XML-SAX-Machines/Makefile b/textproc/p5-XML-SAX-Machines/Makefile
index 2ca05d69b03c..bfa9c91d0cdf 100644
--- a/textproc/p5-XML-SAX-Machines/Makefile
+++ b/textproc/p5-XML-SAX-Machines/Makefile
@@ -34,4 +34,10 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+EXTRA_PATCHES= ${PATCHDIR}/500503-Makefile.PL
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-XML-SAX-Machines/files/500503-Makefile.PL b/textproc/p5-XML-SAX-Machines/files/500503-Makefile.PL
new file mode 100644
index 000000000000..24ed3894a9ae
--- /dev/null
+++ b/textproc/p5-XML-SAX-Machines/files/500503-Makefile.PL
@@ -0,0 +1,12 @@
+--- Makefile.PL.orig Wed Dec 29 20:16:15 2004
++++ Makefile.PL Wed Dec 29 20:18:39 2004
+@@ -49,3 +49,9 @@
+ install_site_config:
+ $(PERL) -I$(PERL_ARCHLIB) -I$(PERL_LIB) -I$(INST_LIB) -I$(INSTALLSITELIB) -MXML::SAX::Machines::ConfigHelper -we 'XML::SAX::Machines::ConfigHelper::_write_site_config_if_absent(shift)' $(INSTALLSITELIB)
+ POSTAMBLE_END
++
++sub MY::manifypods {
++ package MY; my $self=shift;
++ $self->{MAN3PODS}->{'lib/XML/SAX/Machines/ConfigHelper.pm'}='$(INST_MAN3DIR)/XML::SAX::Machines::ConfigHelper.$(MAN3EXT)';
++ $self->SUPER::manifypods(@_);
++}