aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-SAX
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-01-28 12:10:37 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-01-28 12:10:37 +0000
commite2f9b3f65fb46ddbe0d469a33b04e8088d162010 (patch)
tree1ff3431de253c3c41df5e91b48d347d9e9ce81b9 /textproc/p5-XML-SAX
parentc9a94b6d817bff1bfef241e75cb638e40dfd4d14 (diff)
downloadports-e2f9b3f65fb46ddbe0d469a33b04e8088d162010.tar.gz
ports-e2f9b3f65fb46ddbe0d469a33b04e8088d162010.zip
Updated to 1.05
Approved by: tobez
Notes
Notes: svn path=/head/; revision=53903
Diffstat (limited to 'textproc/p5-XML-SAX')
-rw-r--r--textproc/p5-XML-SAX/Makefile19
-rw-r--r--textproc/p5-XML-SAX/distinfo2
-rw-r--r--textproc/p5-XML-SAX/pkg-descr9
3 files changed, 20 insertions, 10 deletions
diff --git a/textproc/p5-XML-SAX/Makefile b/textproc/p5-XML-SAX/Makefile
index 44462d548a58..93127e5e147a 100644
--- a/textproc/p5-XML-SAX/Makefile
+++ b/textproc/p5-XML-SAX/Makefile
@@ -6,23 +6,30 @@
#
PORTNAME= XML-SAX
-PORTVERSION= 0.03
+PORTVERSION= 0.05
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
PKGNAMEPREFIX= p5-
-MAINTAINER= skv@protey.ru
+MAINTAINER= skv@FreeBSD.org
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/NamespaceSupport.pm:${PORTSDIR}/textproc/p5-XML-NamespaceSupport
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
+CONFIGURE_ARGS= </dev/null
-MAN3= XML::SAX.3 XML::SAX::Base.3 XML::SAX::Exception.3 \
- XML::SAX::ParserFactory.3 XML::SAX::PurePerl.3 \
- XML::SAX::PurePerl::Reader.3
+MAN3= XML::SAX.3 XML::SAX::Base.3 XML::SAX::DocumentLocator.3 \
+ XML::SAX::Exception.3 XML::SAX::ParserFactory.3 \
+ XML::SAX::PurePerl.3 XML::SAX::PurePerl::Reader.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+post-configure:
+# dirty hack to deceive irritable pod2man
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 -lax/;' \
+ ${WRKSRC}/Makefile
+
.include <bsd.port.mk>
diff --git a/textproc/p5-XML-SAX/distinfo b/textproc/p5-XML-SAX/distinfo
index f6bb4bfcaf0e..31480b349dd3 100644
--- a/textproc/p5-XML-SAX/distinfo
+++ b/textproc/p5-XML-SAX/distinfo
@@ -1 +1 @@
-MD5 (XML-SAX-0.03.tar.gz) = f4da07ffcd323521407ef5e30620a5d7
+MD5 (XML-SAX-0.05.tar.gz) = 464cd12f7ffa72a0e351fccf64f8f84c
diff --git a/textproc/p5-XML-SAX/pkg-descr b/textproc/p5-XML-SAX/pkg-descr
index 3966f8dcb45e..1c8457f23b25 100644
--- a/textproc/p5-XML-SAX/pkg-descr
+++ b/textproc/p5-XML-SAX/pkg-descr
@@ -1,8 +1,11 @@
XML::SAX consists of several framework classes for using and building
-Perl SAX2 XML parsers, filters, and drivers. It is designed around the
+Perl SAX2 XML parsers, filters, and drivers. It is designed around the
need to be able to "plug in" different SAX parsers to an application
-without requiring programmer intervention. Those of you familiar with
-the DBI will be right at home. Some of the designs come from the Java
+without requiring programmer intervention. Those of you familiar with
+the DBI will be right at home. Some of the designs come from the Java
JAXP specification (SAX part), only without the javaness.
WWW: http://search.cpan.org/search?dist=XML-SAX
+
+-- Sergey Skvortsov
+skv@FreeBSD.org