aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-XQL
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-23 18:08:41 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-23 18:08:41 +0000
commit55273dd8c63e85437f360922ac3ada545f33f9a6 (patch)
tree0ad8f05d04a6f7ba0bdd1626ef1ce073077b2c98 /textproc/p5-XML-XQL
parentbb4117164f72d7de20cea84a72f68b25fc9c23d0 (diff)
downloadports-55273dd8c63e85437f360922ac3ada545f33f9a6.tar.gz
ports-55273dd8c63e85437f360922ac3ada545f33f9a6.zip
New port p5-XML-XQL version 0.67: Perl module for querying XML tree
structures with XQL
Notes
Notes: svn path=/head/; revision=70886
Diffstat (limited to 'textproc/p5-XML-XQL')
-rw-r--r--textproc/p5-XML-XQL/Makefile31
-rw-r--r--textproc/p5-XML-XQL/distinfo1
-rw-r--r--textproc/p5-XML-XQL/pkg-comment1
-rw-r--r--textproc/p5-XML-XQL/pkg-descr15
-rw-r--r--textproc/p5-XML-XQL/pkg-plist14
5 files changed, 62 insertions, 0 deletions
diff --git a/textproc/p5-XML-XQL/Makefile b/textproc/p5-XML-XQL/Makefile
new file mode 100644
index 000000000000..95066a98a07f
--- /dev/null
+++ b/textproc/p5-XML-XQL/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: XML::XQL
+# Date created: Sat Nov 23 17:24:19 UTC 2002
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-XQL
+PORTVERSION= 0.67
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lioux@FreeBSD.org
+
+RUN_DEPENDS= ${PBASE}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${PBASE}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
+ ${PBASE}/Parse/Yapp.pm:${PORTSDIR}/devel/p5-Parse-Yapp \
+ ${PBASE}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= XML::XQL.3 XML::XQL::DOM.3 XML::XQL::Date.3 \
+ XML::XQL::Query.3 XML::XQL::Tutorial.3
+
+PBASE= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-XQL/distinfo b/textproc/p5-XML-XQL/distinfo
new file mode 100644
index 000000000000..de33018fc4b2
--- /dev/null
+++ b/textproc/p5-XML-XQL/distinfo
@@ -0,0 +1 @@
+MD5 (XML-XQL-0.67.tar.gz) = 546986f11a440a6447a52306544d579b
diff --git a/textproc/p5-XML-XQL/pkg-comment b/textproc/p5-XML-XQL/pkg-comment
new file mode 100644
index 000000000000..2076a63a0a56
--- /dev/null
+++ b/textproc/p5-XML-XQL/pkg-comment
@@ -0,0 +1 @@
+Perl module for querying XML tree structures with XQL
diff --git a/textproc/p5-XML-XQL/pkg-descr b/textproc/p5-XML-XQL/pkg-descr
new file mode 100644
index 000000000000..0ac3e4b48b56
--- /dev/null
+++ b/textproc/p5-XML-XQL/pkg-descr
@@ -0,0 +1,15 @@
+This is a Perl extension to XML::Parser. It adds a new 'Style' to
+XML::Parser, called 'Dom', that allows XML::Parser to build an Object
+Oriented datastructure with a DOM Level 1 compliant interface.
+
+The XML::XQL module implements the XQL (XML Query Language) proposal
+submitted to the XSL Working Group in September 1998. The spec can
+be found at
+
+http://www.w3.org/TandS/QL/QL98/pp/xql.html
+
+Most of the contents related to the XQL syntax can also be found
+in the XML::XQL::Tutorial that comes with this distribution. Note
+that XQL is not the same as XML-QL!
+
+WWW: http://search.cpan.org/search?dist=XML-XQL
diff --git a/textproc/p5-XML-XQL/pkg-plist b/textproc/p5-XML-XQL/pkg-plist
new file mode 100644
index 000000000000..4121b6bb025e
--- /dev/null
+++ b/textproc/p5-XML-XQL/pkg-plist
@@ -0,0 +1,14 @@
+bin/xql.pl
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/XQL/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/XQL.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/XQL/DOM.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/XQL/Date.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/XQL/Debug.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/XQL/DirXQL.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/XQL/Parser.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/XQL/Plus.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/XQL/Query.pod
+lib/perl5/site_perl/%%PERL_VER%%/XML/XQL/Strict.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/XQL/Tutorial.pod
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/XQL
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/XML/XQL