aboutsummaryrefslogtreecommitdiff
path: root/textproc/pear-XML_DTD
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-01 01:37:09 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-01 01:37:09 +0000
commitcd4aa0dc19c5d2f63c8c17afcfa917e45b6b657c (patch)
tree8814962066d8db9fcc1275e4a13a68e89a70fed3 /textproc/pear-XML_DTD
parentabfa1820e5f57b2d1a24c7f140e948698ccaadf2 (diff)
downloadports-cd4aa0dc19c5d2f63c8c17afcfa917e45b6b657c.tar.gz
ports-cd4aa0dc19c5d2f63c8c17afcfa917e45b6b657c.zip
Add pear-XML_DTD 0.4.2, parsing of DTD files and DTD validation of XML
files. PR: ports/101081 Submitted by: chinsan <chinsan.tw at gmail.com>
Notes
Notes: svn path=/head/; revision=169271
Diffstat (limited to 'textproc/pear-XML_DTD')
-rw-r--r--textproc/pear-XML_DTD/Makefile31
-rw-r--r--textproc/pear-XML_DTD/distinfo3
-rw-r--r--textproc/pear-XML_DTD/pkg-descr9
3 files changed, 43 insertions, 0 deletions
diff --git a/textproc/pear-XML_DTD/Makefile b/textproc/pear-XML_DTD/Makefile
new file mode 100644
index 000000000000..6a693424b2ad
--- /dev/null
+++ b/textproc/pear-XML_DTD/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: pear-XML_DTD
+# Date created: 2006/07/31
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML_DTD
+PORTVERSION= 0.4.2
+CATEGORIES= textproc devel pear
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Parsing of DTD files and DTD validation of XML files
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
+ ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_DOS2UNIX= yes
+
+CATEGORY= XML
+FILES= DTD/XmlValidator.php DTD.php
+TESTS= attributes.dtd attributes_bad.xml attributes_good.xml \
+ children.dtd children_bad.xml children_good.xml \
+ content.dtd content_bad.xml content_good.xml \
+ nitf-3-1.dtd nitf-fishing.xml package-1.0 package-1.1.dtd \
+ test.php TOTEST xhtml1-strict.dtd
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/textproc/pear-XML_DTD/distinfo b/textproc/pear-XML_DTD/distinfo
new file mode 100644
index 000000000000..634a25f6b208
--- /dev/null
+++ b/textproc/pear-XML_DTD/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/XML_DTD-0.4.2.tgz) = e920218231845ed64b56f293a2a3480c
+SHA256 (PEAR/XML_DTD-0.4.2.tgz) = ca3964ec7253166b478edf18ef9c6e1dc21e883b80d8c19f2b135a33ebf48550
+SIZE (PEAR/XML_DTD-0.4.2.tgz) = 33790
diff --git a/textproc/pear-XML_DTD/pkg-descr b/textproc/pear-XML_DTD/pkg-descr
new file mode 100644
index 000000000000..5b5e69ef4332
--- /dev/null
+++ b/textproc/pear-XML_DTD/pkg-descr
@@ -0,0 +1,9 @@
+PEAR::XML_DTD parsing of DTD files and DTD validation of XML files.
+The XML validation is done with the php sax parser, the xml extension, it
+does not use the domxml extension.
+
+Currently supports most of the current XML spec, including entities,
+elements and attributes. Some uncommon parts of the spec may still be
+unsupported.
+
+WWW: http://pear.php.net/package/XML_DTD/