aboutsummaryrefslogtreecommitdiff
path: root/textproc/pootle/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-09-29 13:46:42 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-09-29 13:46:42 +0000
commit375a0ec6bee5775421bc64941fb5c5f507785ca0 (patch)
tree29ca6dbcf2b67626342fc9c04f702ed3fa8e1261 /textproc/pootle/Makefile
parenteb32217eb3ca1a458c22619b4d068fd3ccf154a7 (diff)
downloadports-375a0ec6bee5775421bc64941fb5c5f507785ca0.tar.gz
ports-375a0ec6bee5775421bc64941fb5c5f507785ca0.zip
- fix overwriting of configuration file in pkg-plist
- fix depends so that pootle works with Python versions other than 2.6 - replace share/pootle with %%DATADIR%% in pkg-plist PR: ports/151065 Approved by: Denis Pokataev <catone@cpan.org> (maintainer)
Notes
Notes: svn path=/head/; revision=262101
Diffstat (limited to 'textproc/pootle/Makefile')
-rw-r--r--textproc/pootle/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/textproc/pootle/Makefile b/textproc/pootle/Makefile
index 7baabfbcd909..d022c25d5b9a 100644
--- a/textproc/pootle/Makefile
+++ b/textproc/pootle/Makefile
@@ -14,9 +14,9 @@ DISTNAME= Pootle-${PORTVERSION}
MAINTAINER= catone@cpan.org
COMMENT= Pootle is a user-friendly web portal for simple translation process
-BUILD_DEPENDS= py*-django>=1.2:${PORTSDIR}/www/py-django \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>=1.2:${PORTSDIR}/www/py-django \
translate-toolkit>=1.8:${PORTSDIR}/textproc/translate-toolkit \
- ${PYTHON_SITELIBDIR}/South-0.7.1-py2.6.egg:${PORTSDIR}/databases/py-south
+ ${PYTHON_PKGNAMEPREFIX}south>=0.7:${PORTSDIR}/databases/py-south
RUN_DEPENDS:= ${BUILD_DEPENDS}
@@ -68,12 +68,12 @@ RUN_DEPENDS+= svn:${PORTSDIR}/devel/subversion
.endif
.if defined(WITH_LUCENE)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/lucene/_lucene.so:${PORTSDIR}/textproc/py-lucene
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}lucene>0:${PORTSDIR}/textproc/py-lucene
.endif
.if defined(WITH_MEMCACHED)
LIB_DEPENDS+= memcached:${PORTSDIR}/databases/libmemcached
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/python_memcached-1.45-py2.6.egg:${PORTSDIR}/databases/py-memcached
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}memcached>=1.45:${PORTSDIR}/databases/py-memcached
.endif
post-patch: