aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-4suite-xml/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-25 23:26:08 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-25 23:26:08 +0000
commit647fb61a382e2113930bfcce6a040cabc0521048 (patch)
treef49c008ca764e340bcfdac34bb963cfb9625a60e /textproc/py-4suite-xml/Makefile
parent25a3d0e408846f5c8b77dced2505ebfd9c2496f0 (diff)
downloadports-647fb61a382e2113930bfcce6a040cabc0521048.tar.gz
ports-647fb61a382e2113930bfcce6a040cabc0521048.zip
update dependencies in textproc/py-4suite-xml port
1. PyExpat is required in order to build the documentation. Most systems have it, but if you're using python-2.3.2_1 or lower, and have not installed textproc/py-expat or textproc/py-xml, then you probably don't have it. 2. Now that 4Suite XML supports DTD validation, there is no support for xmlproc, the validating parser distributed in PyXML. When xmlproc was needed, it had to come from PyXML 0.8+. That restriction is no longer applicable. PR: ports/90831 Submitted by: Mike Brown <mike@skew.org>
Notes
Notes: svn path=/head/; revision=152033
Diffstat (limited to 'textproc/py-4suite-xml/Makefile')
-rw-r--r--textproc/py-4suite-xml/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/textproc/py-4suite-xml/Makefile b/textproc/py-4suite-xml/Makefile
index 29a7661342b1..0944b4487ee9 100644
--- a/textproc/py-4suite-xml/Makefile
+++ b/textproc/py-4suite-xml/Makefile
@@ -7,6 +7,7 @@
PORTNAME= 4Suite-XML
PORTVERSION= 1.0.b3
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= ftp://ftp.4suite.org/pub/4Suite/ \
${MASTER_SITE_SOURCEFORGE}
@@ -24,7 +25,7 @@ USE_PYTHON= 2.2.1+
USE_PYDISTUTILS= yes
WRKSRC= ${WRKDIR}/4Suite-1.0b3
-CONFLICTS= py*-4suite-[01]* py*-xml-0.7*
+CONFLICTS= py*-4suite-[01]*
.include <bsd.port.pre.mk>
@@ -62,6 +63,7 @@ PYDISTUTILS_INSTALLARGS= --without-docs
.else
PYDISTUTILS_BUILDARGS= --with-docs
PYDISTUTILS_INSTALLARGS= --with-docs
+BUILD_DEPENDS= ${PYEXPAT}
.endif
post-install: