aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-4suite
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-11-08 13:25:33 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-11-08 13:25:33 +0000
commit3f5204ff9ed8d41f9ba8b1b85532c9555b71df7c (patch)
tree28306b5c8a4bfc8c613eca97d72e29b8a10cab0d /textproc/py-4suite
parent463dadf6714834fed902b5a021093560a000e63a (diff)
downloadports-3f5204ff9ed8d41f9ba8b1b85532c9555b71df7c.tar.gz
ports-3f5204ff9ed8d41f9ba8b1b85532c9555b71df7c.zip
* USE_PYTHON corrected
* Add CONFLICTS * Suppress redundant display of pkg-message * Update pkg-descr * Fix pkg-plist * Bump PORTREVISION PR: 88129 Submitted by: Mike Brown <mike@skew.org> * Add SHA256
Notes
Notes: svn path=/head/; revision=147569
Diffstat (limited to 'textproc/py-4suite')
-rw-r--r--textproc/py-4suite/Makefile16
-rw-r--r--textproc/py-4suite/distinfo1
-rw-r--r--textproc/py-4suite/pkg-descr8
-rw-r--r--textproc/py-4suite/pkg-plist6
4 files changed, 28 insertions, 3 deletions
diff --git a/textproc/py-4suite/Makefile b/textproc/py-4suite/Makefile
index 75309a7b6a60..0c33a952c76d 100644
--- a/textproc/py-4suite/Makefile
+++ b/textproc/py-4suite/Makefile
@@ -7,6 +7,7 @@
PORTNAME= 4suite
PORTVERSION= 1.0.b1
+PORTREVISION= 1
CATEGORIES= textproc python
MASTER_SITES= ftp://ftp.4suite.org/pub/4Suite/ \
${MASTER_SITE_SOURCEFORGE}
@@ -20,9 +21,11 @@ COMMENT= A collection of Python tools for XML and RDF processing
USE_BZIP2= yes
USE_REINPLACE= yes
REINPLACE_ARGS= -i "" -E
-USE_PYTHON= 2.2+
+USE_PYTHON= 2.2.1+
USE_PYDISTUTILS= yes
+CONFLICTS= py*-4Suite-1* py*-xml-0.7*
+
.include <bsd.port.pre.mk>
BINDIR= bin
@@ -59,6 +62,16 @@ PYDISTUTILS_INSTALLARGS= --without-docs
.else
PYDISTUTILS_BUILDARGS= --with-docs
PYDISTUTILS_INSTALLARGS= --with-docs
+.if exists(${PYTHON_SITELIBDIR}/_bsddb.so) || exists(${PYTHON_SITELIBDIR}/bsddb3/_pybsddb.so)
+PLIST_SUB+= WITH_PYBSDDB=""
+.else
+PLIST_SUB+= WITH_PYBSDDB="@comment "
+.endif
+.if exists(${PYTHON_SITELIBDIR}/_dbxml.so)
+PLIST_SUB+= WITH_PYBDBXML=""
+.else
+PLIST_SUB+= WITH_PYBDBXML="@comment "
+.endif
.endif
post-extract:
@@ -69,6 +82,5 @@ post-install:
.if !defined(NOPORTDOCS)
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/${DOCSDIR}
.endif
- @ ${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/textproc/py-4suite/distinfo b/textproc/py-4suite/distinfo
index 27077a89ba97..bdf16eece939 100644
--- a/textproc/py-4suite/distinfo
+++ b/textproc/py-4suite/distinfo
@@ -1,2 +1,3 @@
MD5 (4Suite-1.0b1.tar.bz2) = d512d79dcbe08584d0b5ba4c9704a820
+SHA256 (4Suite-1.0b1.tar.bz2) = 6fadd7b8260c368cf50d97a7004e05c38c95128504bf46703ffe27217f5f4ede
SIZE (4Suite-1.0b1.tar.bz2) = 1524266
diff --git a/textproc/py-4suite/pkg-descr b/textproc/py-4suite/pkg-descr
index 3adc5139ecbb..2bf21e04f7aa 100644
--- a/textproc/py-4suite/pkg-descr
+++ b/textproc/py-4suite/pkg-descr
@@ -2,8 +2,10 @@
Its major components include the following:
* Ft.Xml.Domlette: A very fast, lightweight XPath-oriented DOM.
+ * Ft.Xml.Sax: A very fast SAX 2 parser.
* Ft.Xml.XPath: An XPath 1.0 implementation for Domlette documents.
* Ft.Xml.Xslt: A robust XSLT 1.0 processor.
+ * Ft.Xml.XUpdate: An XUpdate processor.
* Ft.Rdf: RDF processing tools, including a query/inference language.
* Ft.Server: An integrated document & RDF repository with web access.
* Ft.Lib: Various support libraries that can be used independently.
@@ -11,11 +13,15 @@ Its major components include the following:
4Suite also includes convenient command-line tools:
* 4xml: XML document parsing and reserialization.
* 4xpath: XPath expression evaluation.
- * 4xslt: XSLT processing engine.
+ * 4xslt: XSLT processing.
+ * 4xupdate: XUpdate processing.
* 4rdf: RDF/XML parsing, persistence, querying and reserialization.
* 4ss_manager: Document/RDF repository administration.
* 4ss: Document/RDF repository user commands.
+4Suite 1.0b1 is the last release of the monolithic 4Suite package;
+4Suite XML, 4Suite RDF, and 4Suite Repository are replacing it.
+
WWW: http://4suite.org/
-- Mike Brown <mike@skew.org>
diff --git a/textproc/py-4suite/pkg-plist b/textproc/py-4suite/pkg-plist
index a32b4d73e10d..f3ee6ec2ecda 100644
--- a/textproc/py-4suite/pkg-plist
+++ b/textproc/py-4suite/pkg-plist
@@ -2312,6 +2312,7 @@
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Lib.number.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Rdf.Container.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Rdf.Drivers.BerkeleyDB.html
+%%WITH_PYBSDDB%%%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Rdf.Drivers.BerkeleyDBTxnTable.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Rdf.Drivers.DataBaseExceptions.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Rdf.Drivers.Dbm.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Rdf.Drivers.Memory.html
@@ -2492,6 +2493,10 @@
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Server.Server.Drivers.SessionManager.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Server.Server.Drivers.Util.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Server.Server.Drivers.html
+%%WITH_PYBDBXML%%%%PORTDOCS%%%%DOCSDIR%%/xml/modules/Ft.Server.Server.Drivers.BerkeleyDB.BerkeleyDBContainer.xml
+%%WITH_PYBDBXML%%%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Server.Server.Drivers.BerkeleyDB.BerkeleyDBContainer.html
+%%WITH_PYBDBXML%%%%PORTDOCS%%%%DOCSDIR%%/xml/modules/Ft.Server.Server.Drivers.BerkeleyDB.Util.xml
+%%WITH_PYBDBXML%%%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Server.Server.Drivers.BerkeleyDB.Util.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Server.Server.Drivers.pAclObject.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Server.Server.FtRpc.FtRpcHandler.html
%%PORTDOCS%%%%DOCSDIR%%/html/modules/Ft.Server.Server.FtRpc.html
@@ -2800,6 +2805,7 @@
%%PORTDOCS%%%%DOCSDIR%%/xml/modules/Ft.Lib.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/modules/Ft.Rdf.Container.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/modules/Ft.Rdf.Drivers.BerkeleyDB.xml
+%%WITH_PYBSDDB%%%%PORTDOCS%%%%DOCSDIR%%/xml/modules/Ft.Rdf.Drivers.BerkeleyDBTxnTable.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/modules/Ft.Rdf.Drivers.DataBaseExceptions.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/modules/Ft.Rdf.Drivers.Dbm.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/modules/Ft.Rdf.Drivers.Memory.xml