aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-genshi
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-01-24 09:15:30 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-01-24 09:15:30 +0000
commit9c66313a36fa26d2bba6625422f0b6192d4a9e35 (patch)
tree22153dc8f1d75e7dac241e71ca9ea6fc9029972b /textproc/py-genshi
parent757bcb3ca213ca1580f8ca01fb76cf0868b26322 (diff)
downloadports-9c66313a36fa26d2bba6625422f0b6192d4a9e35.tar.gz
ports-9c66313a36fa26d2bba6625422f0b6192d4a9e35.zip
Genshi is a Python library that provides an integrated set of components
for parsing, generating, and processing HTML, XML or other textual content for output generation on the web. The major feature is a template language, which is heavily inspired by Kid. WWW: http://genshi.wedgewall.org/ Approved by: alexbl (mentor, implicit)
Notes
Notes: svn path=/head/; revision=183158
Diffstat (limited to 'textproc/py-genshi')
-rw-r--r--textproc/py-genshi/Makefile33
-rw-r--r--textproc/py-genshi/distinfo3
-rw-r--r--textproc/py-genshi/files/pkg-deinstall.in17
-rw-r--r--textproc/py-genshi/files/pkg-install.in16
-rw-r--r--textproc/py-genshi/pkg-descr6
5 files changed, 75 insertions, 0 deletions
diff --git a/textproc/py-genshi/Makefile b/textproc/py-genshi/Makefile
new file mode 100644
index 000000000000..c52903370526
--- /dev/null
+++ b/textproc/py-genshi/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-genshi
+# Date created: 2007-01-23
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Genshi
+PORTVERSION= 0.3.6
+#PORTREVISION= 0
+#PORTEPOCH= 0
+CATEGORIES= textproc www python
+MASTER_SITES= http://ftp.edgewall.com/pub/${PORTNAME:L}/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME:L}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@email.it
+COMMENT= Python toolkit for stream-based generation of output for the web
+
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= ${PYTHON_SITELIBDIR:S|${PREFIX}/||}/${PYGENSHI_EGG}
+PYGENSHI_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+SUB_FILES= pkg-deinstall pkg-install
+SUB_LIST= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR} \
+ EGG_VER="${PORTNAME}==${PORTVERSION}"
+
+.include <bsd.port.mk>
diff --git a/textproc/py-genshi/distinfo b/textproc/py-genshi/distinfo
new file mode 100644
index 000000000000..889f2e852c99
--- /dev/null
+++ b/textproc/py-genshi/distinfo
@@ -0,0 +1,3 @@
+MD5 (Genshi-0.3.6.tar.gz) = ea7b7d30d5086b3ce47e41023188ad31
+SHA256 (Genshi-0.3.6.tar.gz) = 7458da5fe248d2c2d08f0a62b5f8bba49fac5f7f78c304a87643b9de9ad64311
+SIZE (Genshi-0.3.6.tar.gz) = 143349
diff --git a/textproc/py-genshi/files/pkg-deinstall.in b/textproc/py-genshi/files/pkg-deinstall.in
new file mode 100644
index 000000000000..766972b4a95e
--- /dev/null
+++ b/textproc/py-genshi/files/pkg-deinstall.in
@@ -0,0 +1,17 @@
+#!/bin/sh
+# $FreeBSD$
+PKGNAME=$1
+#
+case $2 in
+ DEINSTALL)
+ easy_install -q -N -m -x -S %%PYTHON_SITELIBDIR%% %%EGG_VER%%
+ ;;
+ POST-DEINSTALL)
+ exit 0
+ ;;
+ *)
+ echo "Unexpected Argument $2!!!"
+ exit 1
+ ;;
+esac
+exit 0
diff --git a/textproc/py-genshi/files/pkg-install.in b/textproc/py-genshi/files/pkg-install.in
new file mode 100644
index 000000000000..44fdc30f9229
--- /dev/null
+++ b/textproc/py-genshi/files/pkg-install.in
@@ -0,0 +1,16 @@
+#!/bin/sh
+# $FreeBSD$
+PKGNAME=$1
+#
+case $2 in
+ POST-INSTALL)
+ easy_install -q -N -S %%PYTHON_SITELIBDIR%% %%EGG_VER%%
+ ;;
+ PRE-INSTALL)
+ ;;
+ *)
+ echo "Unexpected Argument $2!!!"
+ exit 1
+ ;;
+esac
+exit 0
diff --git a/textproc/py-genshi/pkg-descr b/textproc/py-genshi/pkg-descr
new file mode 100644
index 000000000000..5ce4ed75e14e
--- /dev/null
+++ b/textproc/py-genshi/pkg-descr
@@ -0,0 +1,6 @@
+Genshi is a Python library that provides an integrated set of components
+for parsing, generating, and processing HTML, XML or other textual content
+for output generation on the web. The major feature is a template language,
+which is heavily inspired by Kid.
+
+WWW: http://genshi.wedgewall.org/