aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-libxml2
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-07-06 03:06:13 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-07-06 03:06:13 +0000
commita89f7de8a83341764d2b0d1a201c469664e378f7 (patch)
tree91f166c9746d81af3a51cd9c609fab97202cdb8b /textproc/py-libxml2
parent434197a7ee362fee8d162f620cb1c623b662ae45 (diff)
downloadports-a89f7de8a83341764d2b0d1a201c469664e378f7.tar.gz
ports-a89f7de8a83341764d2b0d1a201c469664e378f7.zip
Add py-libxml2 , Python interface for XML parser library for GNOME.
Notes
Notes: svn path=/head/; revision=113028
Diffstat (limited to 'textproc/py-libxml2')
-rw-r--r--textproc/py-libxml2/Makefile34
-rw-r--r--textproc/py-libxml2/pkg-descr3
-rw-r--r--textproc/py-libxml2/pkg-plist48
3 files changed, 85 insertions, 0 deletions
diff --git a/textproc/py-libxml2/Makefile b/textproc/py-libxml2/Makefile
new file mode 100644
index 000000000000..b34c38755dfd
--- /dev/null
+++ b/textproc/py-libxml2/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: py-libxml2
+# Date created: 30 Jun 2004
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= textproc gnome python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Python interface for XML parser library for GNOME
+
+MASTERDIR= ${.CURDIR}/../libxml2
+BUILD_WRKSRC= ${WRKSRC}/python
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOME= gnomehack gnometarget libxml2
+USE_PYTHON= yes
+CONFIGURE_ARGS= --with-iconv=${LOCALBASE} \
+ --with-html-dir=${PREFIX}/share/doc \
+ --with-html-subdir=${PORTNAME} \
+ --with-python=${LOCALBASE}
+
+DOCSDIR= ${PREFIX}/share/doc/py-libxml2
+EXAMPLESDIR= ${PREFIX}/share/examples/py-libxml2
+
+post-install:
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -l ${PYTHON_SITELIBDIR}
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/py-libxml2/pkg-descr b/textproc/py-libxml2/pkg-descr
new file mode 100644
index 000000000000..afb7cf4dd299
--- /dev/null
+++ b/textproc/py-libxml2/pkg-descr
@@ -0,0 +1,3 @@
+Python interface for XML parser library for GNOME
+
+WWW: http://xmlsoft.org/
diff --git a/textproc/py-libxml2/pkg-plist b/textproc/py-libxml2/pkg-plist
new file mode 100644
index 000000000000..da9629cd51f5
--- /dev/null
+++ b/textproc/py-libxml2/pkg-plist
@@ -0,0 +1,48 @@
+lib/%%PYTHON_VERSION%%/site-packages/drv_libxml2.py
+lib/%%PYTHON_VERSION%%/site-packages/drv_libxml2.pyc
+lib/%%PYTHON_VERSION%%/site-packages/drv_libxml2.pyo
+lib/%%PYTHON_VERSION%%/site-packages/libxml2.py
+lib/%%PYTHON_VERSION%%/site-packages/libxml2.pyc
+lib/%%PYTHON_VERSION%%/site-packages/libxml2.pyo
+lib/%%PYTHON_VERSION%%/site-packages/libxml2mod.so
+%%DOCSDIR%%/TODO
+%%EXAMPLESDIR%%/attribs.py
+%%EXAMPLESDIR%%/build.py
+%%EXAMPLESDIR%%/ctxterror.py
+%%EXAMPLESDIR%%/cutnpaste.py
+%%EXAMPLESDIR%%/error.py
+%%EXAMPLESDIR%%/inbuf.py
+%%EXAMPLESDIR%%/indexes.py
+%%EXAMPLESDIR%%/invalid.xml
+%%EXAMPLESDIR%%/outbuf.py
+%%EXAMPLESDIR%%/push.py
+%%EXAMPLESDIR%%/pushSAX.py
+%%EXAMPLESDIR%%/pushSAXhtml.py
+%%EXAMPLESDIR%%/reader.py
+%%EXAMPLESDIR%%/reader2.py
+%%EXAMPLESDIR%%/reader3.py
+%%EXAMPLESDIR%%/reader4.py
+%%EXAMPLESDIR%%/reader5.py
+%%EXAMPLESDIR%%/reader6.py
+%%EXAMPLESDIR%%/reader7.py
+%%EXAMPLESDIR%%/reader8.py
+%%EXAMPLESDIR%%/readererr.py
+%%EXAMPLESDIR%%/regexp.py
+%%EXAMPLESDIR%%/relaxng.py
+%%EXAMPLESDIR%%/resolver.py
+%%EXAMPLESDIR%%/serialize.py
+%%EXAMPLESDIR%%/sync.py
+%%EXAMPLESDIR%%/thread2.py
+%%EXAMPLESDIR%%/tst.py
+%%EXAMPLESDIR%%/tst.xml
+%%EXAMPLESDIR%%/tstLastError.py
+%%EXAMPLESDIR%%/tstURI.py
+%%EXAMPLESDIR%%/tstxpath.py
+%%EXAMPLESDIR%%/valid.xml
+%%EXAMPLESDIR%%/validate.py
+%%EXAMPLESDIR%%/walker.py
+%%EXAMPLESDIR%%/xpath.py
+%%EXAMPLESDIR%%/xpathext.py
+%%EXAMPLESDIR%%/xpathret.py
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%