aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-martel
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2000-10-26 19:24:42 +0000
committerJames E. Housley <jeh@FreeBSD.org>2000-10-26 19:24:42 +0000
commit8209177b6dea3cc54de77f28751f1c32bcff214c (patch)
treea0767af011591d26cd61edd2a6a553864592f9ff /textproc/py-martel
parentabbab5c43977a22bf5825649d16d8c242a99f502 (diff)
downloadports-8209177b6dea3cc54de77f28751f1c32bcff214c.tar.gz
ports-8209177b6dea3cc54de77f28751f1c32bcff214c.zip
New Port: textproc/py-martel
A parser generator for regular languages, written in Python PR: 22118 Submitted by: Johann Visagie <johann@egenetics.com>
Notes
Notes: svn path=/head/; revision=34274
Diffstat (limited to 'textproc/py-martel')
-rw-r--r--textproc/py-martel/Makefile43
-rw-r--r--textproc/py-martel/distinfo1
-rw-r--r--textproc/py-martel/pkg-comment1
-rw-r--r--textproc/py-martel/pkg-descr16
-rw-r--r--textproc/py-martel/pkg-plist50
5 files changed, 111 insertions, 0 deletions
diff --git a/textproc/py-martel/Makefile b/textproc/py-martel/Makefile
new file mode 100644
index 000000000000..4c95d77cefde
--- /dev/null
+++ b/textproc/py-martel/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: py-martel
+# Date created: 19 October 2000
+# Whom: Johann Visagie <johann@egenetics.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= martel
+PORTVERSION= 0.3
+CATEGORIES= textproc biology python
+MASTER_SITES= http://www.biopython.org/~dalke/Martel/
+PKGNAMEPREFIX= py-
+DISTNAME= Martel-${PORTVERSION}
+
+MAINTAINER= johann@egenetics.com
+
+RUN_DEPENDS= ${PYXML} \
+ ${PYTHON_SITELIBDIR}/TextTools/__init__.py:${PORTSDIR}/textproc/py-mxTextTools
+
+WRKSRC= ${WRKDIR}/Martel-${PORTVERSION}/Martel
+USE_PYTHON= yes
+NO_BUILD= yes
+
+MARTEL_DIR= ${PYTHON_SITELIBDIR}/Martel
+MARTEL_EXAMPLEDIR=${PREFIX}/share/examples/martel
+MARTEL_DOCDIR= ${PREFIX}/share/doc/martel
+
+do-install:
+ @ ${MKDIR} ${MARTEL_DIR}
+ @ (cd ${WRKSRC} && find *.py examples formats test \
+ | cpio --quiet -pdum -R ${BINOWN}:${BINGRP} ${MARTEL_DIR})
+ @ ${MKDIR} ${MARTEL_EXAMPLEDIR}
+ @ ${INSTALL_DATA} ${WRKSRC}/examples/* ${MARTEL_EXAMPLEDIR}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${MARTEL_DOCDIR}
+.for docfile in README HISTORY doc/*
+ @ ${INSTALL_MAN} ${WRKSRC}/${docfile} ${MARTEL_DOCDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/py-martel/distinfo b/textproc/py-martel/distinfo
new file mode 100644
index 000000000000..806bf314eb84
--- /dev/null
+++ b/textproc/py-martel/distinfo
@@ -0,0 +1 @@
+MD5 (Martel-0.3.tar.gz) = 4fc36181c39b564a3dbbacaab59b7ab8
diff --git a/textproc/py-martel/pkg-comment b/textproc/py-martel/pkg-comment
new file mode 100644
index 000000000000..fefc95acc10d
--- /dev/null
+++ b/textproc/py-martel/pkg-comment
@@ -0,0 +1 @@
+A parser generator for regular languages, written in Python
diff --git a/textproc/py-martel/pkg-descr b/textproc/py-martel/pkg-descr
new file mode 100644
index 000000000000..e4352842c123
--- /dev/null
+++ b/textproc/py-martel/pkg-descr
@@ -0,0 +1,16 @@
+Martel is a parser generator, written in Python, which takes a regular
+expression grammer for a format and turns the resultant parsed tree into a
+set of callback events emulating the XML/SAX API.
+
+It was originally intended for use in biocomputing applications (such as
+Biopython - http://www.biopython.org/), where there is often a need to parse
+existing flat and semi-structured file formats. However, it is generally
+applicable to the parsing of such files in all fields of endeavour.
+
+More information on Martel may be found in this conference poster:
+http://www.biopython.org/~dalke/Martel/BOSC2000.poster/
+
+Author: Andrew Dalke <dalke@acm.org>
+WWW: http://www.biopython.org/~dalke/Martel/
+
+-- Johann Visagie <johann@egenetics.com>
diff --git a/textproc/py-martel/pkg-plist b/textproc/py-martel/pkg-plist
new file mode 100644
index 000000000000..563f386d1d35
--- /dev/null
+++ b/textproc/py-martel/pkg-plist
@@ -0,0 +1,50 @@
+lib/%%PYTHON_VERSION%%/site-packages/Martel/Expression.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/Generate.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/Parser.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/RecordReader.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/convert_re.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/README
+lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/pdb1plm.ent
+lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/sample.swissprot
+lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/swissprot2html.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/test.mol
+lib/%%PYTHON_VERSION%%/site-packages/Martel/examples/toxml.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/formats/MDL_10_1996.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/formats/PDB_2_1.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/formats/PIR_3_0.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/formats/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/formats/blastall_2_0_10.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/formats/swissprot38.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/optimize.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/sre_constants.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/sre_parse.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/support.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_Expression.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_Generate.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_MDL_10_1996.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_PDB_2_1.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_PIR_3_0.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_ParseRecords.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_RecordReader.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_blastall_2_0_10.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_convert_re.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_optimize.py
+lib/%%PYTHON_VERSION%%/site-packages/Martel/test/test_swissprot38.py
+share/doc/martel/HISTORY
+share/doc/martel/README
+share/doc/martel/tech_description.txt
+share/doc/martel/writing_a_format.txt
+share/examples/martel/README
+share/examples/martel/pdb1plm.ent
+share/examples/martel/sample.swissprot
+share/examples/martel/swissprot2html.py
+share/examples/martel/test.mol
+share/examples/martel/toxml.py
+@dirrm share/examples/martel
+@dirrm share/doc/martel
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/Martel/test
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/Martel/formats
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/Martel/examples
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/Martel