aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-wordnet/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-26 07:04:38 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-26 07:04:38 +0000
commit85add070c29266cc9d03899ca4ef3c7184c4c231 (patch)
tree9abc9464e90dc4151859e86e2011d04c62668543 /textproc/py-wordnet/Makefile
parenta00c774372a4680c82535ac6b0e096bf26038482 (diff)
downloadports-85add070c29266cc9d03899ca4ef3c7184c4c231.tar.gz
ports-85add070c29266cc9d03899ca4ef3c7184c4c231.zip
add py-wordnet 1.4
Python Interface to WordNet PR: 36323 Submitted by: Hye-Shik Chang <perky@fallin.lv>
Notes
Notes: svn path=/head/; revision=56681
Diffstat (limited to 'textproc/py-wordnet/Makefile')
-rw-r--r--textproc/py-wordnet/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/py-wordnet/Makefile b/textproc/py-wordnet/Makefile
new file mode 100644
index 000000000000..0014d0f9e66c
--- /dev/null
+++ b/textproc/py-wordnet/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: py-wordnet
+# Date created: 26 March 2002
+# Whom: Hye-Shik Chang <perky@fallin.lv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wordnet
+PORTVERSION= 1.4
+CATEGORIES= textproc python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pywordnet
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pywordnet-${PORTVERSION}
+
+MAINTAINER= perky@fallin.lv
+
+RUN_DEPENDS= ${WORDNETBASE}/lexnames:${PORTSDIR}/textproc/wordnet
+
+USE_PYTHON= yes
+SETUP_CMD= cd ${WRKSRC} && ${PYTHON_CMD} setup.py
+WORDNETBASE?= ${LOCALBASE}/share/wordnet-${WORDNET_VERSION}
+WORDNET_VERSION?= 1.7
+
+post-patch:
+ @${SED} -e 's|/usr/local/wordnet1.6|${WORDNETBASE}|g' \
+ -e 's|os.path.join(WNHOME.*))|WNHOME)|g' ${WRKSRC}/wordnet.py \
+ > ${WRKSRC}/wordnet.py.tmp && ${CAT} ${WRKSRC}/wordnet.py.tmp \
+ > ${WRKSRC}/wordnet.py
+
+do-build:
+ ${SETUP_CMD} build
+
+do-install:
+ ${SETUP_CMD} install -c -O1 --prefix=${PREFIX}
+
+.include <bsd.port.mk>