aboutsummaryrefslogtreecommitdiff
path: root/textproc/raptor2/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-04-23 13:25:16 +0000
commitaad09bc5e23eb75a7a865a8b0002fbc6e13d4659 (patch)
tree69c07cdc4812f0f8be0cc44c38513f540c058778 /textproc/raptor2/Makefile
parent5c818b158c5b9479669f8322b4da8c48f5c30ef9 (diff)
downloadports-aad09bc5e23eb75a7a865a8b0002fbc6e13d4659.tar.gz
ports-aad09bc5e23eb75a7a865a8b0002fbc6e13d4659.zip
When linking a library libA with a library libB using libtool, if libB.la
exists, libtool will add all libraries libB.la refers to (dependency_libs field) to the linker command line and store them in the dependency_libs field of libA.la. So everything that subsequently links with libA will also link to these extra libraries. This causes too much overlinking. This commit modifies Mk/Uses/libtool.mk so it empties the dependency_libs field in .la libraries during staging. However, because .la libraries have very limited use when dependency_libs is empty it makes sense to completely remove them during staging. So with this commit USES=libtool is modified to remove .la libraries and a new form (USES=libtool:keepla) is introduced in case they need to be kept (dependency_libs is still emptied). PORTREVISION is bumped on all ports with USES=libtool that install .la libraries. Most ports are also changed to add :keepla because .la libraries have to be kept around as long as there are dependent ports with .la libraries that refer to them in their dependency_libs field. In most cases :keepla can be removed again as soon as all dependent ports that install .la libraries have some form of USES=libtool added to their Makefile. PR: ports/188759 Exp-run: bdrewery Approved by: portmgr (bdrewery)
Notes
Notes: svn path=/head/; revision=351936
Diffstat (limited to 'textproc/raptor2/Makefile')
-rw-r--r--textproc/raptor2/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/textproc/raptor2/Makefile b/textproc/raptor2/Makefile
index 44ce97a012cb..83162d1f2b6e 100644
--- a/textproc/raptor2/Makefile
+++ b/textproc/raptor2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= raptor2
PORTVERSION= 2.0.13
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc
MASTER_SITES= http://download.librdf.org/source/ \
SF/librdf/${PORTNAME}/${PORTVERSION}
@@ -23,7 +23,7 @@ LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
CONFLICTS= raptor-1.4.1[0-9]* raptor-1.4.21
USE_GNOME= libxml2 libxslt
-USES= pathfix pkgconfig libtool
+USES= libtool:keepla pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-xml2-config=${LOCALBASE}/bin/xml2-config \
--with-curl-config=${LOCALBASE}/bin/curl-config \