aboutsummaryrefslogtreecommitdiff
path: root/textproc/redland
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-22 07:03:00 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-22 07:03:00 +0000
commit4bff3754b15fadbcceff88f773130a5f9033db15 (patch)
tree2b4cfc76e711c852e7d8d350c29dc8a5d375433d /textproc/redland
parent5b63b2b0cbe7eb2954167ad807f5bbc2afe4d50a (diff)
downloadports-4bff3754b15fadbcceff88f773130a5f9033db15.tar.gz
ports-4bff3754b15fadbcceff88f773130a5f9033db15.zip
add redland
A high-level interface for RDF
Notes
Notes: svn path=/head/; revision=50358
Diffstat (limited to 'textproc/redland')
-rw-r--r--textproc/redland/Makefile30
-rw-r--r--textproc/redland/distinfo1
-rw-r--r--textproc/redland/pkg-comment1
-rw-r--r--textproc/redland/pkg-descr7
-rw-r--r--textproc/redland/pkg-plist26
5 files changed, 65 insertions, 0 deletions
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
new file mode 100644
index 000000000000..d4b37d2da6c3
--- /dev/null
+++ b/textproc/redland/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: redland
+# Date created: Nov 22, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= redland
+PORTVERSION= 0.9.10
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.redland.opensource.ac.uk/dist/source/
+MASTER_SITE_SUBDIR= librdf
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= xmlparse.1:${PORTSDIR}/www/libwww \
+ expat.2:${PORTSDIR}/textproc/expat2 \
+ gdbm:${PORTSDIR}/databases/gdbm \
+ db2:${PORTSDIR}/databases/db
+
+USE_OPENSSL= yes
+LIBWWW_CONFIG= ${LOCALBASE}/bin/libwww-config
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} `${LIBWWW_CONFIG} --cflags` -I${LOCALBASE}/include/db2" \
+ LDFLAGS="`${LIBWWW_CONFIG} --libs`"
+CONFIGURE_ARGS= --with-bdb=${LOCALBASE} --with-libwww
+
+.include <bsd.port.mk>
diff --git a/textproc/redland/distinfo b/textproc/redland/distinfo
new file mode 100644
index 000000000000..a01b3fbe81ed
--- /dev/null
+++ b/textproc/redland/distinfo
@@ -0,0 +1 @@
+MD5 (redland-0.9.10.tar.gz) = ad7016755bd1b4203649d002f8715193
diff --git a/textproc/redland/pkg-comment b/textproc/redland/pkg-comment
new file mode 100644
index 000000000000..5a5b6757e5f5
--- /dev/null
+++ b/textproc/redland/pkg-comment
@@ -0,0 +1 @@
+A high-level interface for RDF
diff --git a/textproc/redland/pkg-descr b/textproc/redland/pkg-descr
new file mode 100644
index 000000000000..81c9d69caf0a
--- /dev/null
+++ b/textproc/redland/pkg-descr
@@ -0,0 +1,7 @@
+Redland is a library that provides a high-level interface for RDF allowing
+the model to be stored, queried and manipulated. Redland implements each
+of the RDF model concepts in its own class so provides an object based API
+for them. Some of the classes providing the parsers, storage mechanisms and
+other elements are built as modules that can be added or removed as required.
+
+WWW: http://www.redland.opensource.ac.uk/
diff --git a/textproc/redland/pkg-plist b/textproc/redland/pkg-plist
new file mode 100644
index 000000000000..e4ee08508c4e
--- /dev/null
+++ b/textproc/redland/pkg-plist
@@ -0,0 +1,26 @@
+bin/redland-config
+include/librdf.h
+include/rdf_concepts.h
+include/rdf_digest.h
+include/rdf_files.h
+include/rdf_hash.h
+include/rdf_hash_bdb.h
+include/rdf_hash_gdbm.h
+include/rdf_hash_memory.h
+include/rdf_heuristics.h
+include/rdf_init.h
+include/rdf_iterator.h
+include/rdf_list.h
+include/rdf_model.h
+include/rdf_node.h
+include/rdf_parser.h
+include/rdf_statement.h
+include/rdf_storage.h
+include/rdf_storage_hashes.h
+include/rdf_storage_list.h
+include/rdf_stream.h
+include/rdf_types.h
+include/rdf_uri.h
+include/rdf_utf8.h
+include/redland.h
+lib/librdf.a