aboutsummaryrefslogtreecommitdiff
path: root/textproc/redland
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2002-07-15 21:43:23 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2002-07-15 21:43:23 +0000
commitc85753e63ab6bddfc0d0e757e1db47b108dfcf87 (patch)
treefd23f0a1150a9b29e1f62a07eb0111f5df36e4ac /textproc/redland
parenta135889b1832244679ef26208ae8c6be8cfbe597 (diff)
downloadports-c85753e63ab6bddfc0d0e757e1db47b108dfcf87.tar.gz
ports-c85753e63ab6bddfc0d0e757e1db47b108dfcf87.zip
Update to version 0.9.11
PR: 40628 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=63045
Diffstat (limited to 'textproc/redland')
-rw-r--r--textproc/redland/Makefile25
-rw-r--r--textproc/redland/distinfo2
-rw-r--r--textproc/redland/files/patch-configure10
-rw-r--r--textproc/redland/pkg-plist5
4 files changed, 33 insertions, 9 deletions
diff --git a/textproc/redland/Makefile b/textproc/redland/Makefile
index d4b37d2da6c3..a1ff845d9b4d 100644
--- a/textproc/redland/Makefile
+++ b/textproc/redland/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= redland
-PORTVERSION= 0.9.10
+PORTVERSION= 0.9.11
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.redland.opensource.ac.uk/dist/source/
@@ -15,16 +15,25 @@ MASTER_SITE_SUBDIR= librdf
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= xmlparse.1:${PORTSDIR}/www/libwww \
+LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db \
+ gdbm.2:${PORTSDIR}/databases/gdbm \
expat.2:${PORTSDIR}/textproc/expat2 \
- gdbm:${PORTSDIR}/databases/gdbm \
- db2:${PORTSDIR}/databases/db
+ xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xmlparse.1:${PORTSDIR}/www/libwww
+
+LIBWWW_CONFIG?= ${LOCALBASE}/bin/libwww-config
USE_OPENSSL= yes
-LIBWWW_CONFIG= ${LOCALBASE}/bin/libwww-config
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} `${LIBWWW_CONFIG} --cflags` -I${LOCALBASE}/include/db2" \
- LDFLAGS="`${LIBWWW_CONFIG} --libs`"
+USE_PERL5= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-bdb=${LOCALBASE} --with-libwww
+INSTALLS_SHLIB= yes
+
+MAN3= redland.3
+
+CPPFLAGS= -I${LOCALBASE}/include/db2 -I${LOCALBASE}/include \
+ `${LIBWWW_CONFIG} --cflags`
+LDFLAGS= -L${LOCALBASE}/lib `${LIBWWW_CONFIG} --libs`
.include <bsd.port.mk>
diff --git a/textproc/redland/distinfo b/textproc/redland/distinfo
index a01b3fbe81ed..afadccae632e 100644
--- a/textproc/redland/distinfo
+++ b/textproc/redland/distinfo
@@ -1 +1 @@
-MD5 (redland-0.9.10.tar.gz) = ad7016755bd1b4203649d002f8715193
+MD5 (redland-0.9.11.tar.gz) = 3aa452e98b6a16f804843ba9df106daf
diff --git a/textproc/redland/files/patch-configure b/textproc/redland/files/patch-configure
new file mode 100644
index 000000000000..c101d5ce12cc
--- /dev/null
+++ b/textproc/redland/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sun Jun 9 05:34:13 2002
++++ configure Tue Jul 16 04:47:28 2002
+@@ -5610,6 +5610,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/textproc/redland/pkg-plist b/textproc/redland/pkg-plist
index e4ee08508c4e..a245c351ea57 100644
--- a/textproc/redland/pkg-plist
+++ b/textproc/redland/pkg-plist
@@ -14,6 +14,9 @@ include/rdf_list.h
include/rdf_model.h
include/rdf_node.h
include/rdf_parser.h
+include/rdf_query.h
+include/rdf_query_triples.h
+include/rdf_serializer.h
include/rdf_statement.h
include/rdf_storage.h
include/rdf_storage_hashes.h
@@ -24,3 +27,5 @@ include/rdf_uri.h
include/rdf_utf8.h
include/redland.h
lib/librdf.a
+lib/librdf.so
+lib/librdf.so.0