aboutsummaryrefslogtreecommitdiff
path: root/textproc/rman/files
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2003-06-25 12:21:54 +0000
committerThomas Gellekum <tg@FreeBSD.org>2003-06-25 12:21:54 +0000
commitc583c7157f87de80f620774c6affdf71aa680cc0 (patch)
tree435f940da68a01fd224fc7ab9ec3396c49bfabc0 /textproc/rman/files
parente822a053445e1cabde979315cf16f4c48c1bfa64 (diff)
downloadports-c583c7157f87de80f620774c6affdf71aa680cc0.tar.gz
ports-c583c7157f87de80f620774c6affdf71aa680cc0.zip
Fix segmentation fault on invalid input.
PR: 49998 Submitted by: IIJIMA Hiromitsu <delmonta@ht.sakura.ne.jp> Upgrade to 3.1. Disown this port.
Notes
Notes: svn path=/head/; revision=83581
Diffstat (limited to 'textproc/rman/files')
-rw-r--r--textproc/rman/files/patch-aa14
-rw-r--r--textproc/rman/files/patch-rman.c26
2 files changed, 33 insertions, 7 deletions
diff --git a/textproc/rman/files/patch-aa b/textproc/rman/files/patch-aa
index d64b141037f1..c016d9049107 100644
--- a/textproc/rman/files/patch-aa
+++ b/textproc/rman/files/patch-aa
@@ -1,14 +1,14 @@
-*** Makefile.orig Wed Jun 21 18:05:56 2000
---- Makefile Mon Jun 26 20:15:01 2000
+diff -c /home/tg/work/FreeBSD/ports/local/rman/work/rman-3.1/Makefile.orig /home/tg/work/FreeBSD/ports/local/rman/work/rman-3.1/Makefile
+*** /home/tg/work/FreeBSD/ports/local/rman/work/rman-3.1/Makefile.orig Sun Mar 30 00:45:20 2003
+--- /home/tg/work/FreeBSD/ports/local/rman/work/rman-3.1/Makefile Mon May 12 18:50:36 2003
***************
-*** 15,31 ****
+*** 15,30 ****
# this must be a directory that's in your bin PATH.
# MANDIR holds the man page.
! BINDIR = /usr/local/bin
#BINDIR = //C/bin
-! MANDIR = /home/auspex/h/bair/phelps/man/man1
-! #MANDIR = /usr/local/man/man1
+! MANDIR = /usr/local/man/man1
### if you have GNU gcc v2.x, use these definitions
@@ -19,13 +19,12 @@
### if you just have a standard UNIX, use these instead of GNU.
### CC must be an ANSI C compiler
---- 15,31 ----
+--- 15,30 ----
# this must be a directory that's in your bin PATH.
# MANDIR holds the man page.
! BINDIR = ${PREFIX}/bin
#BINDIR = //C/bin
-! #MANDIR = /home/auspex/h/bair/phelps/man/man1
! MANDIR = ${PREFIX}/man/man1
@@ -37,3 +36,4 @@
### if you just have a standard UNIX, use these instead of GNU.
### CC must be an ANSI C compiler
+
diff --git a/textproc/rman/files/patch-rman.c b/textproc/rman/files/patch-rman.c
new file mode 100644
index 000000000000..4568c0637b54
--- /dev/null
+++ b/textproc/rman/files/patch-rman.c
@@ -0,0 +1,26 @@
+diff -c /home/tg/work/FreeBSD/ports/local/rman/work/rman-3.1/rman.c.orig /home/tg/work/FreeBSD/ports/local/rman/work/rman-3.1/rman.c
+--- /home/tg/work/FreeBSD/ports/local/rman/work/rman-3.1/rman.c.orig Sun Mar 30 00:45:18 2003
++++ /home/tg/work/FreeBSD/ports/local/rman/work/rman-3.1/rman.c Mon May 12 18:59:41 2003
+@@ -3729,11 +3729,15 @@
+ q=strchr(p, ' ');
+ if (q!=NULL) *q++='\0';
+ strcpy(manName, p);
+- for (p=q; isspace(*p); p++) /*nada*/;
+- if (*p) {
+- q=strchr(p,' ');
+- if (q!=NULL) *q++='\0';
+- strcpy(manSect, p);
++ if (q) {
++ for (p=q; isspace(*p); p++) /*nada*/;
++ if (*p) {
++ q=strchr(p,' ');
++ if (q!=NULL) *q++='\0';
++ strcpy(manSect, p);
++ }
++ } else {
++ strcpy(manSect, "?");
+ }
+ }
+ sI=0;
+
+