aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-amatch
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-11-10 17:41:06 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-11-10 17:41:06 +0000
commita9bcda55c25808c6d83a03fcdd6b8c3e611643c8 (patch)
treee33b3f03b3e943cfc28bf3f4c99b2fa21d260c64 /textproc/ruby-amatch
parent1cc520232fd05c2a43b076aa65d939a284617992 (diff)
downloadports-a9bcda55c25808c6d83a03fcdd6b8c3e611643c8.tar.gz
ports-a9bcda55c25808c6d83a03fcdd6b8c3e611643c8.zip
Add ruby-amatch, a Ruby library for approximate string matching and
searching.
Notes
Notes: svn path=/head/; revision=69818
Diffstat (limited to 'textproc/ruby-amatch')
-rw-r--r--textproc/ruby-amatch/Makefile35
-rw-r--r--textproc/ruby-amatch/distinfo1
-rw-r--r--textproc/ruby-amatch/pkg-comment1
-rw-r--r--textproc/ruby-amatch/pkg-descr6
-rw-r--r--textproc/ruby-amatch/pkg-plist6
5 files changed, 49 insertions, 0 deletions
diff --git a/textproc/ruby-amatch/Makefile b/textproc/ruby-amatch/Makefile
new file mode 100644
index 000000000000..b64d86eebdfb
--- /dev/null
+++ b/textproc/ruby-amatch/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Ruby/amatch
+# Date created: 10 November 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= amatch
+PORTVERSION= 0.1.1
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.ping.de/~flori/programs/ruby/amatch/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+INSTALL_TARGET= site-install
+
+DOCS= CHANGES README.en amatch.txt.en
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-amatch/distinfo b/textproc/ruby-amatch/distinfo
new file mode 100644
index 000000000000..ea457d5f1c34
--- /dev/null
+++ b/textproc/ruby-amatch/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/amatch-0.1.1.tgz) = c5a7a9d5421ef21d22cb9c7ae8272eda
diff --git a/textproc/ruby-amatch/pkg-comment b/textproc/ruby-amatch/pkg-comment
new file mode 100644
index 000000000000..2dedd25d809e
--- /dev/null
+++ b/textproc/ruby-amatch/pkg-comment
@@ -0,0 +1 @@
+A Ruby library for approximate string matching and searching
diff --git a/textproc/ruby-amatch/pkg-descr b/textproc/ruby-amatch/pkg-descr
new file mode 100644
index 000000000000..f7d86b4c1ece
--- /dev/null
+++ b/textproc/ruby-amatch/pkg-descr
@@ -0,0 +1,6 @@
+This is a Ruby library for approximate string matching and searching
+using a dynamic programming algorithm to compute the Levenstein
+distance between strings. Written in C for speed.
+
+Author: Florian Frank <flori@ping.de>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=amatch
diff --git a/textproc/ruby-amatch/pkg-plist b/textproc/ruby-amatch/pkg-plist
new file mode 100644
index 000000000000..4e838cff21fb
--- /dev/null
+++ b/textproc/ruby-amatch/pkg-plist
@@ -0,0 +1,6 @@
+bin/agrep.rb
+%%RUBY_SITEARCHLIBDIR%%/amatch.so
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/CHANGES
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README.en
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/amatch.txt.en
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%