aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-htmlsplit/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-09-20 05:03:25 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-09-20 05:03:25 +0000
commitcbec7ec0b5dfd25ee57bd87d6d0fe138b11a0645 (patch)
tree6ae43785b579a9ffca6c6f2fa47339c1a69fe80c /textproc/ruby-htmlsplit/Makefile
parentb3fc8349ed371ac06e2632fe91bcb19ee8f600ea (diff)
downloadports-cbec7ec0b5dfd25ee57bd87d6d0fe138b11a0645.tar.gz
ports-cbec7ec0b5dfd25ee57bd87d6d0fe138b11a0645.zip
Add ruby-htmlsplit, a Ruby library to split an HTML document into an
array of tags and contents.
Notes
Notes: svn path=/head/; revision=47999
Diffstat (limited to 'textproc/ruby-htmlsplit/Makefile')
-rw-r--r--textproc/ruby-htmlsplit/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/ruby-htmlsplit/Makefile b/textproc/ruby-htmlsplit/Makefile
new file mode 100644
index 000000000000..b3c84aa83686
--- /dev/null
+++ b/textproc/ruby-htmlsplit/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: htmlsplit.rb
+# Date created: 20 September 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= htmlsplit
+PORTVERSION= 1.0.2
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.moonwolf.com/ruby/archive/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//g}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_ZIP= yes
+USE_RUBY= yes
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/htmlsplit.rb ${RUBY_SITELIBDIR}/
+
+.include <bsd.port.mk>