aboutsummaryrefslogtreecommitdiff
path: root/textproc/ruby-libxml
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-07-12 05:47:44 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-07-12 05:47:44 +0000
commite147182622d87c27a5717564b094edee31ccc70b (patch)
tree24c1352fe6315f6230f9eeb46d3da292fb895e50 /textproc/ruby-libxml
parentf36fcd52f273a1b1112ed822369105c8042e515b (diff)
downloadports-e147182622d87c27a5717564b094edee31ccc70b.tar.gz
ports-e147182622d87c27a5717564b094edee31ccc70b.zip
Add ruby-libxml (version 0.01), a libxml2 binding for Ruby with both
libxml and Ruby APIs. PR: ports/40392 Submitted by: Sean Chittenden <sean@chittenden.org>
Notes
Notes: svn path=/head/; revision=62846
Diffstat (limited to 'textproc/ruby-libxml')
-rw-r--r--textproc/ruby-libxml/Makefile26
-rw-r--r--textproc/ruby-libxml/distinfo1
-rw-r--r--textproc/ruby-libxml/pkg-comment1
-rw-r--r--textproc/ruby-libxml/pkg-descr8
-rw-r--r--textproc/ruby-libxml/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/textproc/ruby-libxml/Makefile b/textproc/ruby-libxml/Makefile
new file mode 100644
index 000000000000..7e0c9316b1df
--- /dev/null
+++ b/textproc/ruby-libxml/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ruby-libxml
+# Date created: 09 July 2002
+# Whom: Sean Chittenden <sean@chittenden.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxml
+PORTVERSION= 0.01
+CATEGORIES= textproc ruby
+MASTER_SITES= http://www.rubynet.org/modules/xml/ruby-libxml/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-20020709
+
+MAINTAINER= sean@chittenden.org
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/xml2-config:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+#LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+INSTALL_TARGET= site-install
+
+.include <bsd.port.mk>
diff --git a/textproc/ruby-libxml/distinfo b/textproc/ruby-libxml/distinfo
new file mode 100644
index 000000000000..47489c8e321e
--- /dev/null
+++ b/textproc/ruby-libxml/distinfo
@@ -0,0 +1 @@
+MD5 (ruby-libxml-20020709.tar.gz) = 5f3c7c31a6f23b23c65cc3b8cc0e92d1
diff --git a/textproc/ruby-libxml/pkg-comment b/textproc/ruby-libxml/pkg-comment
new file mode 100644
index 000000000000..c0445b1a31f8
--- /dev/null
+++ b/textproc/ruby-libxml/pkg-comment
@@ -0,0 +1 @@
+A libxml2 binding for Ruby with both libxml and Ruby APIs
diff --git a/textproc/ruby-libxml/pkg-descr b/textproc/ruby-libxml/pkg-descr
new file mode 100644
index 000000000000..ce04c0a55cb3
--- /dev/null
+++ b/textproc/ruby-libxml/pkg-descr
@@ -0,0 +1,8 @@
+ruby-libxml provies a clean, Ruby-style interface into the libxml2
+library. None of the power and granularity of libxml's data
+structures are lost with the API (that glosses over the low-level XML
+structures).
+
+Author: Sean Chittenden <sean@chittenden.org>
+
+WWW: http://cvsweb.rubydoc.org/cgi-bin/cvsweb.cgi/projects/ruby-libxml/?cvsroot=rubynet
diff --git a/textproc/ruby-libxml/pkg-plist b/textproc/ruby-libxml/pkg-plist
new file mode 100644
index 000000000000..3bc636cf3eb4
--- /dev/null
+++ b/textproc/ruby-libxml/pkg-plist
@@ -0,0 +1 @@
+%%RUBY_SITEARCHLIBDIR%%/libxml.so